<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
    <meta charset="UTF-8">
    <meta name="viewport" content="width=device-width, initial-scale=1"/>
    <!--[if lt IE 9]>
    <script src="https://html5shiv.googlecode.com/svn/trunk/html5.js"></script>
    <![endif]-->
	<title>Stack Overflow: Helping One Million Developers Exit Vim - Stack Overflow Blog</title>

<!-- This site is optimized with the Yoast SEO plugin v4.6 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://stackoverflow.blog/2017/05/23/stack-overflow-helping-one-million-developers-exit-vim/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Stack Overflow: Helping One Million Developers Exit Vim - Stack Overflow Blog" />
<meta property="og:description" content="This morning, a popular Stack Overflow question hit a major milestone:" />
<meta property="og:url" content="https://stackoverflow.blog/2017/05/23/stack-overflow-helping-one-million-developers-exit-vim/" />
<meta property="og:site_name" content="Stack Overflow Blog" />
<meta property="article:publisher" content="https://www.facebook.com/officialstackoverflow/" />
<meta property="article:section" content="Announcements" />
<meta property="article:published_time" content="2017-05-23T13:00:30-04:00" />
<meta property="article:modified_time" content="2017-05-23T14:59:13-04:00" />
<meta property="og:updated_time" content="2017-05-23T14:59:13-04:00" />
<meta property="og:image" content="https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exitvim-1024x455.png" />
<meta property="og:image" content="https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/practicaldev-1-229x300.jpg" />
<meta property="og:image" content="https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/meme.jpeg" />
<meta property="og:image" content="https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_over_time-1-1024x1024.png" />
<meta property="og:image" content="https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/country_stuck_vim-1-2-1024x1024.png" />
<meta property="og:image" content="https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_by_language-1-3-1024x1024.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="This morning, a popular Stack Overflow question hit a major milestone:" />
<meta name="twitter:title" content="Stack Overflow: Helping One Million Developers Exit Vim - Stack Overflow Blog" />
<meta name="twitter:site" content="@StackOverflow" />
<meta name="twitter:image" content="https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exitvim-1024x455.png" />
<meta name="twitter:creator" content="@drob" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Stack Overflow Blog &raquo; Stack Overflow: Helping One Million Developers Exit Vim Comments Feed" href="https://stackoverflow.blog/2017/05/23/stack-overflow-helping-one-million-developers-exit-vim/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/stackoverflow.blog\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='stack-css'  href='https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/themes/stackoverflow/assets/css/stackoverflow.min.css?ver=0.1.3' type='text/css' media='all' />
<script type='text/javascript' src='https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://stackoverflow.blog/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://stackoverflow.blog/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://stackoverflow.blog/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://stackoverflow.blog/?p=7147' />
<link rel="alternate" type="application/json+oembed" href="https://stackoverflow.blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstackoverflow.blog%2F2017%2F05%2F23%2Fstack-overflow-helping-one-million-developers-exit-vim%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://stackoverflow.blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstackoverflow.blog%2F2017%2F05%2F23%2Fstack-overflow-helping-one-million-developers-exit-vim%2F&#038;format=xml" />
		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		<link rel="icon" href="https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/03/cropped-SO_Logo_glyph-use-this-one-smaller-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/03/cropped-SO_Logo_glyph-use-this-one-smaller-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/03/cropped-SO_Logo_glyph-use-this-one-smaller-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/03/cropped-SO_Logo_glyph-use-this-one-smaller-270x270.jpg" />
</head>
<body class="post-template-default single single-post postid-7147 single-format-standard container">

<div class="index-nav">
	    <header class="header transparent">
        <div class="mainnav-wrapper">
            <nav class="mainnav horizontal-nav">
                <div class="hlogo -item">
                    <a class="current -nav-link hlogo-link" href="https://stackoverflow.blog"></a>
                </div>
				            </nav>

			                <nav class="horizontal-nav">
                    <div class="-item">
                        <a class="-nav-link"
                           href="https://stackoverflow.blog/engineering/">All Posts</a>
                    </div>
                </nav>
			
        </div>
    </header>
	    </div>
    <div id="primary" class="content-area">
        <main id="main" class="site-main" role="main">

            
    <article class="post full-post" data-id="7147">
		            <div class="hero  no-image">
				                <div class="inner-container media-padded">
					
					<h1 class="h2">Stack Overflow: Helping One Million Developers Exit Vim</h1>					<div class="author-container"><span class="author vcard"><a class="url fn n" href="https://stackoverflow.blog/authors/drobinson/"><img src="//stackoverflow.blog/wp-content/uploads/2017/02/mCoc7.jpg"></a><h2 class="h4 author-name">by <a class="url fn n" href="https://stackoverflow.blog/authors/drobinson/">David Robinson</a></h2></span><div class="date">on <time class="entry-date published updated" datetime="2017-05-23T13:00:30+00:00">May 23, 2017</time></div></div>                </div>
            </div>
            <div class="inner-container">
                <div class="entry">
					    <div class="social-sharing">
        <!-- Go to www.addthis.com/dashboard to customize your tools -->
        <div class="addthis_inline_share_toolbox" data-url="https://stackoverflow.blog/2017/05/23/stack-overflow-helping-one-million-developers-exit-vim/"
             data-title="Stack Overflow: Helping One Million Developers Exit Vim" ></div>
    </div>


                    <div class="media-padded">
						<p>This morning, a <a href="https://stackoverflow.com/questions/11828270/how-to-exit-the-vim-editor">popular Stack Overflow question</a> hit a major milestone:</p>
<p><img src="https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exitvim-1024x455.png" alt="" width="1024" height="455" class="alignnone size-large wp-image-7148" srcset="https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exitvim-1024x455.png 1024w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exitvim-300x133.png 300w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exitvim-768x341.png 768w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exitvim-400x178.png 400w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exitvim-800x356.png 800w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exitvim-1200x534.png 1200w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exitvim.png 1462w " sizes="(max-width: 1024px) 100vw, 1024px" /></p>
<p>You&#8217;re not alone, jclancy. In the five years since this question was asked, there have been over a million other developers who got stuck in Vim and couldn&#8217;t escape without a bit of help. Indeed, the difficulty of quitting the Vim editor is a common joke among developers.</p>
<p><img src="https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/practicaldev-1-229x300.jpg" alt="" width="229" height="300" class="alignnone size-medium wp-image-7159" srcset="https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/practicaldev-1-229x300.jpg 229w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/practicaldev-1-768x1008.jpg 768w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/practicaldev-1-781x1024.jpg 781w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/practicaldev-1-152x200.jpg 152w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/practicaldev-1-305x400.jpg 305w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/practicaldev-1-457x600.jpg 457w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/practicaldev-1-610x800.jpg 610w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/practicaldev-1-762x1000.jpg 762w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/practicaldev-1-915x1200.jpg 915w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/practicaldev-1-1524x2000.jpg 1524w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/practicaldev-1.jpg 1561w " sizes="(max-width: 229px) 100vw, 229px" /></p>
<p><img src="https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/meme.jpeg" alt="" width="324" height="318" class="alignnone size-full wp-image-7150" srcset="https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/meme.jpeg 324w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/meme-300x294.jpeg 300w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/meme-204x200.jpeg 204w " sizes="(max-width: 324px) 100vw, 324px" /></p>
<p>I&#8217;ve been told by experienced Vim users that this reputation is unfair, and I&#8217;m sure they&#8217;re right (even I&#8217;ve gotten the hang of it in the last few years). I think there are two reasons it&#8217;s easy to forget how to exit Vim: developers are often dropped into Vim from a git command or another situation where they didn&#8217;t expect to be, and they run into it infrequently enough to forget how they solved it last time.</p>
<p>In honor of this milestone, we decided to take a look at the data surrounding this question. In particular, we&#8217;ll try measuring who is most likely to get <strong>stuck</strong> in Vim as opposed to using it intentionally, and examining how that balance varies by country and by programming language.</p>
<h3>How many people have been struggling to exit Vim?</h3>
<p>In the last year, <a href="http://stackoverflow.com/questions/11828270/how-to-exit-the-vim-editor">How to exit the Vim editor</a> has made up about .005% of question traffic: that is, one out of every 20,000 visits to Stack Overflow questions. That means during peak traffic hours on weekdays, there are about 80 people per hour that need help getting out of Vim.</p>
<p>Has the percentage of traffic it makes up changed over time? That is, have developers started learning to exit Vim on their own?</p>
<p><img src="https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_over_time-1-1024x1024.png" alt="" width="1024" height="1024" class="alignnone size-large wp-image-7151" srcset="https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_over_time-1-1024x1024.png 1024w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_over_time-1-150x150.png 150w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_over_time-1-300x300.png 300w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_over_time-1-768x768.png 768w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_over_time-1-200x200.png 200w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_over_time-1-400x400.png 400w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_over_time-1-600x600.png 600w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_over_time-1-800x800.png 800w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_over_time-1-1000x1000.png 1000w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_over_time-1-1200x1200.png 1200w " sizes="(max-width: 1024px) 100vw, 1024px" /></p>
<p>It doesn&#8217;t look like it. The question was asked in August 2012, and for a few months it got very little traffic. Then it began growing in the following two years, presumably as more sources linked to it online and it moved to the top of search engine results. It&#8217;s been relatively steady for the last two years. This doesn&#8217;t necessarily mean the same people visited it again and again, of course; it could represent relatively new programmers getting stuck in Vim for the first time.</p>
<h3>Differences across countries</h3>
<p>As we saw in <a href="https://stackoverflow.blog/2016/11/30/how-do-developers-in-new-york-san-francisco-london-and-bangalore-differ/">a previous blog post</a>, we can use Stack Overflow traffic to learn a lot about the geographical distribution of developers.</p>
<p>Let&#8217;s consider what percentage of <em>visits to Vim</em> this question comprises within each country. In countries with a lot of experienced Vim users, we&#8217;d expect this percentage to be low. When it&#8217;s high, it indicates many users got stuck in Vim when they didn&#8217;t necessarily expect to.</p>
<p><img src="https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/country_stuck_vim-1-2-1024x1024.png" alt="" width="1024" height="1024" class="alignnone size-large wp-image-7167" srcset="https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/country_stuck_vim-1-2-1024x1024.png 1024w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/country_stuck_vim-1-2-150x150.png 150w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/country_stuck_vim-1-2-300x300.png 300w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/country_stuck_vim-1-2-768x768.png 768w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/country_stuck_vim-1-2-200x200.png 200w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/country_stuck_vim-1-2-400x400.png 400w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/country_stuck_vim-1-2-600x600.png 600w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/country_stuck_vim-1-2-800x800.png 800w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/country_stuck_vim-1-2-1000x1000.png 1000w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/country_stuck_vim-1-2-1200x1200.png 1200w " sizes="(max-width: 1024px) 100vw, 1024px" /></p>
<p>It looks like developers in Ukraine, Turkey and Indonesia are getting stuck in Vim quite a bit: it makes up a larger portion of their Vim questions than in any other country. In contrast, in China, Korea and Japan the fraction going to this question is one-tenth as much. That might indicate that when developers in these countries enter Vim, they usually meant to do so, and they know how to get out of it.</p>
<h3>What kind of programmers get stuck in Vim?</h3>
<p>It&#8217;s also likely that users of different programming languages will have different experiences with Vim. We can investigate this by stratifying the &#8220;Exit Vim / Total Vim&#8221; percentage across each user&#8217;s <strong>main programming technology</strong>.</p>
<p>We&#8217;ll define this based on what Stack Overflow tag they visit most often. (For instance, my most visited tag is <a href="https://stackoverflow.com/questions/tagged/r">R</a>: it makes up 52% of my question views). It&#8217;s not a perfect measure, but it&#8217;s reliable enough to give a sense of the breakdown by language. (For this analysis, we considered only registered users with at least 100 visits to the site).</p>
<p><img src="https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_by_language-1-3-1024x1024.png" alt="" width="1024" height="1024" class="alignnone size-large wp-image-7168" srcset="https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_by_language-1-3-1024x1024.png 1024w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_by_language-1-3-150x150.png 150w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_by_language-1-3-300x300.png 300w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_by_language-1-3-768x768.png 768w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_by_language-1-3-200x200.png 200w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_by_language-1-3-400x400.png 400w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_by_language-1-3-600x600.png 600w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_by_language-1-3-800x800.png 800w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_by_language-1-3-1000x1000.png 1000w , https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/uploads/2017/05/exit_vim_by_language-1-3-1200x1200.png 1200w " sizes="(max-width: 1024px) 100vw, 1024px" /></p>
<p>The developers who are most likely to get stuck in Vim are front-end web developers: those who primarily visit tags like JQuery, CSS, and AngularJS. They&#8217;re followed by Microsoft developers (C# and SQL Server) and mobile (Android and iOS). These developers usually work with an IDE (Visual Studio, Eclipse, Xcode, and so on), rather than a plain text editor, so it makes sense that they&#8217;re relatively more likely to get &#8220;stuck&#8221; in Vim rather than to open it intentionally.</p>
<p>The developers least likely to get stuck in Vim are those who program in C, C++, Python and Ruby. These languages make sense to me: they are a combination of low-level languages and scripting languages that are often used with a plain text editor rather than an IDE, so they have the experience to escape it without a Google search.</p>
<h3>Conclusion</h3>
<p>I was amused when I saw this question approach a million visits, but I was also proud that I work for, and contribute answers to, a site that helps so many developers. You never know when an answer you contribute could help millions of people, whether it shares how to <a href="https://stackoverflow.com/questions/927358/how-to-undo-last-commits-in-git">undo a git commit</a> or how <a href="https://stackoverflow.com/questions/231767/what-does-the-yield-keyword-do-in-python">the yield keyword in Python works</a>.</p>
<p>If you want to contribute yourself, we encourage you to <a href="https://stackoverflow.com/users/login?utm_source=so-owned&amp;utm_medium=blog&amp;utm_campaign=gen-blog&amp;utm_content=blog-link">join the world&#8217;s largest developer community</a>, whether it&#8217;s to ask and answer questions, get your next job, or <a href="https://stackoverflow.blog/2016/10/11/bye-bye-bullets-the-stack-overflow-developer-story-is-the-new-technical-resume/">build your online presence with a Developer Story</a>. You can also use tools like <a href="https://insights.stackoverflow.com/trends?utm_source=so-owned&#038;utm_medium=blog&#038;utm_campaign=trends&#038;utm_content=blog-link">Stack Overflow Trends</a> to learn more about what our data can tell you about software developers.</p>
<p>In any case, next time you solve your problem through Stack Overflow, remember the hundreds of thousands of users who regularly ask, answer, edit, and moderate the site to make it all possible.</p>
                        <div class="metadata -row">
                            <div class="-col6 _textLeft">
                                <p>By
                                    <a href="https://stackoverflow.blog/authors/drobinson/">David Robinson</a><span>, Data Scientist</span>
										                                </p>
                            </div>
                            <div class="-col6 _textRight">
                                <p><strong>Tagged in</strong>&nbsp;
                                    <span class="post-tags"><a href="https://stackoverflow.blog/tags/announcements/" rel="category tag">Announcements</a> <a href="https://stackoverflow.blog/company/" rel="category tag">Company</a> <a href="https://stackoverflow.blog/tags/data/" rel="category tag">Data</a> <a href="https://stackoverflow.blog/engineering/" rel="category tag">Engineering</a></span>
                            </div>
                        </div>
                    </div>
                    <div class="disqus media-padded">
						
<div class="comments">
	
<div id="disqus_thread">
            <div id="dsq-content">


            <ul id="dsq-comments">
                    <li class="comment even thread-even depth-1" id="dsq-comment-2131">
        <div id="dsq-comment-header-2131" class="dsq-comment-header">
            <cite id="dsq-cite-2131">
                <span id="dsq-author-user-2131">Vijay Kumar Attri</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2131" class="dsq-comment-body">
            <div id="dsq-comment-message-2131" class="dsq-comment-message"><p>Good read. 😀</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-2132">
        <div id="dsq-comment-header-2132" class="dsq-comment-header">
            <cite id="dsq-cite-2132">
                <span id="dsq-author-user-2132">Anirudh Mathad</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2132" class="dsq-comment-body">
            <div id="dsq-comment-message-2132" class="dsq-comment-message"><p>VIMter is coming!</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even thread-even depth-1" id="dsq-comment-2133">
        <div id="dsq-comment-header-2133" class="dsq-comment-header">
            <cite id="dsq-cite-2133">
                <span id="dsq-author-user-2133">Jon</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2133" class="dsq-comment-body">
            <div id="dsq-comment-message-2133" class="dsq-comment-message"><p>The guy that wrote the original answer is the chief architect of MaidSafe!!</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-2134">
        <div id="dsq-comment-header-2134" class="dsq-comment-header">
            <cite id="dsq-cite-2134">
                <span id="dsq-author-user-2134">Alejandro Matias Ravasio</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2134" class="dsq-comment-body">
            <div id="dsq-comment-message-2134" class="dsq-comment-message"><p>&#8220;For instance, my most visited tag is R&#8221;<br />
After this post, I am not surprised. :v</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even thread-even depth-1" id="dsq-comment-2135">
        <div id="dsq-comment-header-2135" class="dsq-comment-header">
            <cite id="dsq-cite-2135">
                <span id="dsq-author-user-2135">vivekgani</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2135" class="dsq-comment-body">
            <div id="dsq-comment-message-2135" class="dsq-comment-message"><p>Brilliant, but where&#8217;s the Larry Tesler #nomodes reference?</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-2136">
        <div id="dsq-comment-header-2136" class="dsq-comment-header">
            <cite id="dsq-cite-2136">
                <span id="dsq-author-user-2136">Morgan Feldon</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2136" class="dsq-comment-body">
            <div id="dsq-comment-message-2136" class="dsq-comment-message"><p>I could memorize how to use Vim. I&#8217;d just have to erase my childhood and other unnecessary memories to make room. Hopefully it works out better for me than Keanu.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2144">
        <div id="dsq-comment-header-2144" class="dsq-comment-header">
            <cite id="dsq-cite-2144">
                <span id="dsq-author-user-2144">Dutchie</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2144" class="dsq-comment-body">
            <div id="dsq-comment-message-2144" class="dsq-comment-message"><p>using vim has been the only worthwhile childhood memory for me.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2138">
        <div id="dsq-comment-header-2138" class="dsq-comment-header">
            <cite id="dsq-cite-2138">
                <a id="dsq-author-user-2138" href="https://about.me/ghoshsourav" target="_blank" rel="nofollow">Sourav Ghosh</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2138" class="dsq-comment-body">
            <div id="dsq-comment-message-2138" class="dsq-comment-message"><p>Another form of asking the same question. 😛</p>
<p> <a href="https://uploads.disquscdn.com/images/f8b55f9896a83979d871ffb517da8d44ac363325adbbbe5ea405d7ab5dff5948.jpg" rel="nofollow">https://uploads.disquscdn.com/images/f8b55f9896a83979d871ffb517da8d44ac363325adbbbe5ea405d7ab5dff5948.jpg</a></p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2139">
        <div id="dsq-comment-header-2139" class="dsq-comment-header">
            <cite id="dsq-cite-2139">
                <a id="dsq-author-user-2139" href="https://vgaidarji.me" target="_blank" rel="nofollow">Veaceslav Gaidarji</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2139" class="dsq-comment-body">
            <div id="dsq-comment-message-2139" class="dsq-comment-message"><p>I&#8217;m always searching at SO how to &#8220;visual block edit in vim&#8221;. Tried to memorize, but always failing to do it correctly from first attempt 🙂</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2140">
        <div id="dsq-comment-header-2140" class="dsq-comment-header">
            <cite id="dsq-cite-2140">
                <span id="dsq-author-user-2140">DimaNYC</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2140" class="dsq-comment-body">
            <div id="dsq-comment-message-2140" class="dsq-comment-message"><p><a href="https://uploads.disquscdn.com/images/8eb5ec59b591f0a7b64b1da3c2289862ec0cf286973cf19d074bac019669904b.png" rel="nofollow">https://uploads.disquscdn.com/images/8eb5ec59b591f0a7b64b1da3c2289862ec0cf286973cf19d074bac019669904b.png</a></p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2145">
        <div id="dsq-comment-header-2145" class="dsq-comment-header">
            <cite id="dsq-cite-2145">
                <span id="dsq-author-user-2145">Josué Morales</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2145" class="dsq-comment-body">
            <div id="dsq-comment-message-2145" class="dsq-comment-message"><p>jajajaja</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2170">
        <div id="dsq-comment-header-2170" class="dsq-comment-header">
            <cite id="dsq-cite-2170">
                <span id="dsq-author-user-2170">Irvandoval</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2170" class="dsq-comment-body">
            <div id="dsq-comment-message-2170" class="dsq-comment-message"><p>lol</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2141">
        <div id="dsq-comment-header-2141" class="dsq-comment-header">
            <cite id="dsq-cite-2141">
                <span id="dsq-author-user-2141">Cameron</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2141" class="dsq-comment-body">
            <div id="dsq-comment-message-2141" class="dsq-comment-message"><p>I love that this is a thing</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2142">
        <div id="dsq-comment-header-2142" class="dsq-comment-header">
            <cite id="dsq-cite-2142">
                <span id="dsq-author-user-2142">Tilghman Lesher</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2142" class="dsq-comment-body">
            <div id="dsq-comment-message-2142" class="dsq-comment-message"><p>Could be worse.  They could be stuck trying to exit Emacs.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2158">
        <div id="dsq-comment-header-2158" class="dsq-comment-header">
            <cite id="dsq-cite-2158">
                <span id="dsq-author-user-2158">Bishop Clark</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2158" class="dsq-comment-body">
            <div id="dsq-comment-message-2158" class="dsq-comment-message"><p>That WOULD be terrible &#8212; if you&#8217;re trying to leave, you&#8217;re not using it right.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2201">
        <div id="dsq-comment-header-2201" class="dsq-comment-header">
            <cite id="dsq-cite-2201">
                <span id="dsq-author-user-2201">Tilghman Lesher</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2201" class="dsq-comment-body">
            <div id="dsq-comment-message-2201" class="dsq-comment-message"><p>Could even be worse.  They could be trying to save on a terminal with software flow control.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2164">
        <div id="dsq-comment-header-2164" class="dsq-comment-header">
            <cite id="dsq-cite-2164">
                <span id="dsq-author-user-2164">Lliamander</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2164" class="dsq-comment-body">
            <div id="dsq-comment-message-2164" class="dsq-comment-message"><p>Lol! I remember the days of first learning Emacs&#8230;, but at least Emacs at least has a navigable menu bar with mouse support (even in TUI mode). Of course, using it is shameful thing one should never admit to ;).</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-2143">
        <div id="dsq-comment-header-2143" class="dsq-comment-header">
            <cite id="dsq-cite-2143">
                <a id="dsq-author-user-2143" href="http://www.mager.co/" target="_blank" rel="nofollow">mager</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2143" class="dsq-comment-body">
            <div id="dsq-comment-message-2143" class="dsq-comment-message"><p>`:q!`</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2149">
        <div id="dsq-comment-header-2149" class="dsq-comment-header">
            <cite id="dsq-cite-2149">
                <span id="dsq-author-user-2149">Heath Snoek</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2149" class="dsq-comment-body">
            <div id="dsq-comment-message-2149" class="dsq-comment-message"><p>Always save you work, you dolt!</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2161">
        <div id="dsq-comment-header-2161" class="dsq-comment-header">
            <cite id="dsq-cite-2161">
                <span id="dsq-author-user-2161">DimaNYC</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2161" class="dsq-comment-body">
            <div id="dsq-comment-message-2161" class="dsq-comment-message"><p>I am a `:x` kinda guy</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2169">
        <div id="dsq-comment-header-2169" class="dsq-comment-header">
            <cite id="dsq-cite-2169">
                <span id="dsq-author-user-2169">S Stewart</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2169" class="dsq-comment-body">
            <div id="dsq-comment-message-2169" class="dsq-comment-message"><p>I&#8217;ll take :wq thank you very much.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2184">
        <div id="dsq-comment-header-2184" class="dsq-comment-header">
            <cite id="dsq-cite-2184">
                <span id="dsq-author-user-2184">Mark Anderson</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2184" class="dsq-comment-body">
            <div id="dsq-comment-message-2184" class="dsq-comment-message"><p>depends. Did I accidentally open something? but yeah, I find myself doing :wq in atom all the time.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-4" id="dsq-comment-2245">
        <div id="dsq-comment-header-2245" class="dsq-comment-header">
            <cite id="dsq-cite-2245">
                <span id="dsq-author-user-2245">kbielefe</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2245" class="dsq-comment-body">
            <div id="dsq-comment-message-2245" class="dsq-comment-message"><p>Well, in these users&#8217; cases, it&#8217;s more like, &#8220;Did I accidentally open vim then type a bunch of normal mode commands that made a whole bunch of edits I have no idea how to undo?&#8221;</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2146">
        <div id="dsq-comment-header-2146" class="dsq-comment-header">
            <cite id="dsq-cite-2146">
                <span id="dsq-author-user-2146">Braiam</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2146" class="dsq-comment-body">
            <div id="dsq-comment-message-2146" class="dsq-comment-message"><p>How it fares in per capita? Stuck in vim/vim users in country and stuck in vim/programmers in country?</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2147">
        <div id="dsq-comment-header-2147" class="dsq-comment-header">
            <cite id="dsq-cite-2147">
                <a id="dsq-author-user-2147" href="http://ansel.co" target="_blank" rel="nofollow">Ansel Santosa</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2147" class="dsq-comment-body">
            <div id="dsq-comment-message-2147" class="dsq-comment-message"><p>This is hilarious. I want to see the OS breakdown!</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2153">
        <div id="dsq-comment-header-2153" class="dsq-comment-header">
            <cite id="dsq-cite-2153">
                <a id="dsq-author-user-2153" href="http://zerquix18.com/" target="_blank" rel="nofollow">I&#8217;m Luis!</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2153" class="dsq-comment-body">
            <div id="dsq-comment-message-2153" class="dsq-comment-message"><p>Linux 100%</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-3" id="dsq-comment-2227">
        <div id="dsq-comment-header-2227" class="dsq-comment-header">
            <cite id="dsq-cite-2227">
                <span id="dsq-author-user-2227">Frédéric Delaporte</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2227" class="dsq-comment-body">
            <div id="dsq-comment-message-2227" class="dsq-comment-message"><p>I would rather bet for a high windows percentage. Haven&#8217;t you read wholly the article? It even gives a hint at why we may guess that: Git dropping you to vim in some circumstances. It does that under windows too. There, windows dev having no knowledge of vi are very likely to get stuck. (I have only used Git under windows, but I am also a long time user of Linux. I was quite surprised when Git first dropped me in vim, but that was not an issue for me.)</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2150">
        <div id="dsq-comment-header-2150" class="dsq-comment-header">
            <cite id="dsq-cite-2150">
                <span id="dsq-author-user-2150">DeAca</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2150" class="dsq-comment-body">
            <div id="dsq-comment-message-2150" class="dsq-comment-message"><p>My country is not in the list&#8230; is that meaning we never get stuck???<br />
🙂<br />
&#8230;or is it because we learn first to use kill -9 and then VIM?<br />
:-)&#8230;:-)&#8230;. :ZZ</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2166">
        <div id="dsq-comment-header-2166" class="dsq-comment-header">
            <cite id="dsq-cite-2166">
                <span id="dsq-author-user-2166">jacks</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2166" class="dsq-comment-body">
            <div id="dsq-comment-message-2166" class="dsq-comment-message"><p>Your country may not have more than the 100 million visits needed to make the cut.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2181">
        <div id="dsq-comment-header-2181" class="dsq-comment-header">
            <cite id="dsq-cite-2181">
                <span id="dsq-author-user-2181">Koen Dejonghe</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2181" class="dsq-comment-body">
            <div id="dsq-comment-message-2181" class="dsq-comment-message"><p>your country (like mine) probably uses notepad.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-4" id="dsq-comment-2202">
        <div id="dsq-comment-header-2202" class="dsq-comment-header">
            <cite id="dsq-cite-2202">
                <span id="dsq-author-user-2202">DeAca</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2202" class="dsq-comment-body">
            <div id="dsq-comment-message-2202" class="dsq-comment-message"><p>Uhmmm&#8230;more like edlin maybe!<br />
🙂</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-2151">
        <div id="dsq-comment-header-2151" class="dsq-comment-header">
            <cite id="dsq-cite-2151">
                <span id="dsq-author-user-2151">Andrew Leach</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2151" class="dsq-comment-body">
            <div id="dsq-comment-message-2151" class="dsq-comment-message"><p>&#8220;In contrast, in China, Korea and Japan the fraction going to this question is a tenth smaller. That might indicate that when developers in these countries enter Vim, they usually meant to do so, and they know how to get out of it.&#8221;</p>
<p>While users of Vim in countries with non-Latin, multi-byte alphabets might know how to quit the editor if they can get it to work, it may be that the number of users is tiny because getting it to work is hard, and getting stuck is the least of their problems with it.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2157">
        <div id="dsq-comment-header-2157" class="dsq-comment-header">
            <cite id="dsq-cite-2157">
                <span id="dsq-author-user-2157">Drew</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2157" class="dsq-comment-body">
            <div id="dsq-comment-message-2157" class="dsq-comment-message"><p>It may also indicate that SO is rather irrelevant in those countries, as is Google.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2165">
        <div id="dsq-comment-header-2165" class="dsq-comment-header">
            <cite id="dsq-cite-2165">
                <span id="dsq-author-user-2165">jacks</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2165" class="dsq-comment-body">
            <div id="dsq-comment-message-2165" class="dsq-comment-message"><p>It&#8217;s a percentage of vim users visiting SO, however. So it already accounts for people who are only visiting SO. How they actually calculated that, who knows.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-even depth-1" id="dsq-comment-2154">
        <div id="dsq-comment-header-2154" class="dsq-comment-header">
            <cite id="dsq-cite-2154">
                <a id="dsq-author-user-2154" href="https://www.google.com" target="_blank" rel="nofollow">Martin Tee</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2154" class="dsq-comment-body">
            <div id="dsq-comment-message-2154" class="dsq-comment-message"><p>This is great. Thanks for making this a thing.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-2155">
        <div id="dsq-comment-header-2155" class="dsq-comment-header">
            <cite id="dsq-cite-2155">
                <a id="dsq-author-user-2155" href="http://www.marcanuy.com/" target="_blank" rel="nofollow">Marcelo Canina</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2155" class="dsq-comment-body">
            <div id="dsq-comment-message-2155" class="dsq-comment-message"><p>I thought I would read an answer on how to switch to Emacs 8) </p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2168">
        <div id="dsq-comment-header-2168" class="dsq-comment-header">
            <cite id="dsq-cite-2168">
                <span id="dsq-author-user-2168">Ashok</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2168" class="dsq-comment-body">
            <div id="dsq-comment-message-2168" class="dsq-comment-message"><p>Same here, I thought SO is helping people move from vim to emacs, lol</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2156">
        <div id="dsq-comment-header-2156" class="dsq-comment-header">
            <cite id="dsq-cite-2156">
                <span id="dsq-author-user-2156">Timothy Choi</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2156" class="dsq-comment-body">
            <div id="dsq-comment-message-2156" class="dsq-comment-message"><p>I think the reason Chinese developers are not getting stuck in Vim is because they&#8217;re not using Linux in the first place. Most of them are on Windows.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2159">
        <div id="dsq-comment-header-2159" class="dsq-comment-header">
            <cite id="dsq-cite-2159">
                <a id="dsq-author-user-2159" href="http://www.marcanuy.com/" target="_blank" rel="nofollow">Marcelo Canina</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2159" class="dsq-comment-body">
            <div id="dsq-comment-message-2159" class="dsq-comment-message"><p>You can use Vim in Windows</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2167">
        <div id="dsq-comment-header-2167" class="dsq-comment-header">
            <cite id="dsq-cite-2167">
                <span id="dsq-author-user-2167">mo</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2167" class="dsq-comment-body">
            <div id="dsq-comment-message-2167" class="dsq-comment-message"><p>It&#8217;s much less likely that a Windows user opens Vim accidentally and isn&#8217;t able to close it</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-4" id="dsq-comment-2177">
        <div id="dsq-comment-header-2177" class="dsq-comment-header">
            <cite id="dsq-cite-2177">
                <a id="dsq-author-user-2177" href="http://www.marcanuy.com/" target="_blank" rel="nofollow">Marcelo Canina</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2177" class="dsq-comment-body">
            <div id="dsq-comment-message-2177" class="dsq-comment-message"><p>So? I didn&#8217;t say the opposite. ¯_(ツ)_/ ¯</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-5" id="dsq-comment-2520">
        <div id="dsq-comment-header-2520" class="dsq-comment-header">
            <cite id="dsq-cite-2520">
                <span id="dsq-author-user-2520">mo</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2520" class="dsq-comment-body">
            <div id="dsq-comment-message-2520" class="dsq-comment-message"><p>Context.<br />
Doesn&#8217;t matter whether you can use Vim on Windows if it doesn&#8217;t happen by accident.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-5" id="dsq-comment-2526">
        <div id="dsq-comment-header-2526" class="dsq-comment-header">
            <cite id="dsq-cite-2526">
                <a id="dsq-author-user-2526" href="http://www.marcanuy.com/" target="_blank" rel="nofollow">Marcelo Canina</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2526" class="dsq-comment-body">
            <div id="dsq-comment-message-2526" class="dsq-comment-message"><p>Sure, 100% of Windows users know what they are doing all the time.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-5" id="dsq-comment-2528">
        <div id="dsq-comment-header-2528" class="dsq-comment-header">
            <cite id="dsq-cite-2528">
                <span id="dsq-author-user-2528">mo</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2528" class="dsq-comment-body">
            <div id="dsq-comment-message-2528" class="dsq-comment-message"><p>Now you&#8217;re just being silly on purpose.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2160">
        <div id="dsq-comment-header-2160" class="dsq-comment-header">
            <cite id="dsq-cite-2160">
                <a id="dsq-author-user-2160" href="https://www.google.com" target="_blank" rel="nofollow">Martin Tee</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2160" class="dsq-comment-body">
            <div id="dsq-comment-message-2160" class="dsq-comment-message"><p>From my experience, this does not hold true. 100% of my Chinese friends are all on Arch.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2190">
        <div id="dsq-comment-header-2190" class="dsq-comment-header">
            <cite id="dsq-cite-2190">
                <span id="dsq-author-user-2190">Timothy Choi</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2190" class="dsq-comment-body">
            <div id="dsq-comment-message-2190" class="dsq-comment-message"><p>The last time I had to work with Chinese developers was a while ago so I could be wrong, but then I was working on Discuz! so I guess the community is different.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2162">
        <div id="dsq-comment-header-2162" class="dsq-comment-header">
            <cite id="dsq-cite-2162">
                <a id="dsq-author-user-2162" href="http://stackoverflow.com/users/63550/peter-mortensen" target="_blank" rel="nofollow">Peter Mortensen</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2162" class="dsq-comment-body">
            <div id="dsq-comment-message-2162" class="dsq-comment-message"><p>Emacs is much worse. At least it is easy to remember for Vim (&#8216;q&#8217; for quit).</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2173">
        <div id="dsq-comment-header-2173" class="dsq-comment-header">
            <cite id="dsq-cite-2173">
                <a id="dsq-author-user-2173" href="https://github.com/westoque" target="_blank" rel="nofollow">William Estoque</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2173" class="dsq-comment-body">
            <div id="dsq-comment-message-2173" class="dsq-comment-message"><p>You&#8217;re treading dangerous water there my friend. Be careful 🙂</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2176">
        <div id="dsq-comment-header-2176" class="dsq-comment-header">
            <cite id="dsq-cite-2176">
                <span id="dsq-author-user-2176">asd</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2176" class="dsq-comment-body">
            <div id="dsq-comment-message-2176" class="dsq-comment-message"><p>pfff windows, what a pleb</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2179">
        <div id="dsq-comment-header-2179" class="dsq-comment-header">
            <cite id="dsq-cite-2179">
                <a id="dsq-author-user-2179" href="http://www.marcanuy.com/" target="_blank" rel="nofollow">Marcelo Canina</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2179" class="dsq-comment-body">
            <div id="dsq-comment-message-2179" class="dsq-comment-message"><p>Spacemacs to the rescue.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2197">
        <div id="dsq-comment-header-2197" class="dsq-comment-header">
            <cite id="dsq-cite-2197">
                <span id="dsq-author-user-2197">Matt Williams</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2197" class="dsq-comment-body">
            <div id="dsq-comment-message-2197" class="dsq-comment-message"><p>Actually, ^X^C is the standard syntax for emacs&#8230;. on any platform I&#8217;ve ever used.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2239">
        <div id="dsq-comment-header-2239" class="dsq-comment-header">
            <cite id="dsq-cite-2239">
                <span id="dsq-author-user-2239">Mike</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2239" class="dsq-comment-body">
            <div id="dsq-comment-message-2239" class="dsq-comment-message"><p>Not in the actual Emacs editor itself.  Run &#8220;emacs&#8221; with no arguments and observe the syntax in which shortcut keys are listed.  But I guess you&#8217;ve never used the emacs platform.  😀</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-4" id="dsq-comment-2425">
        <div id="dsq-comment-header-2425" class="dsq-comment-header">
            <cite id="dsq-cite-2425">
                <a id="dsq-author-user-2425" href="http://scorcher.org/" target="_blank" rel="nofollow">Jym Dyer</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2425" class="dsq-comment-body">
            <div id="dsq-comment-message-2425" class="dsq-comment-message"><p>What an odd thing to guess.  Run &#8220;emacs -q&#8221; for a no-init-file startup, actually.  Your first screen has a standard toolbar with a standard File -&gt; Quit sequence.  The main display has an &#8220;Emacs Tutorial Learn basic keystroke commands&#8221; link that you click or hit RETURN on, and the first thing it tells you is to use the CTRL key and type C-x C-c to exit.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2221">
        <div id="dsq-comment-header-2221" class="dsq-comment-header">
            <cite id="dsq-cite-2221">
                <a id="dsq-author-user-2221" href="http://kernelcoffee.org/" target="_blank" rel="nofollow">Kernelcoffee</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2221" class="dsq-comment-body">
            <div id="dsq-comment-message-2221" class="dsq-comment-message"><p>Actually it&#8217;s:<br />
Ctrl + X -&gt; command mode<br />
Ctrl + C -&gt; Terminate process (like a terminal process)</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2224">
        <div id="dsq-comment-header-2224" class="dsq-comment-header">
            <cite id="dsq-cite-2224">
                <span id="dsq-author-user-2224">MadeInNY</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2224" class="dsq-comment-body">
            <div id="dsq-comment-message-2224" class="dsq-comment-message"><p>Emacs being non-modal doesn&#8217;t need you to change states before the commands you know will work.<br />
Intuitive is not a real thing. You&#8217;re gonna have to learn commands no matter what editor you use. So with emacs, at least you only need to type them once.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2163">
        <div id="dsq-comment-header-2163" class="dsq-comment-header">
            <cite id="dsq-cite-2163">
                <span id="dsq-author-user-2163">Cher Stewart</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2163" class="dsq-comment-body">
            <div id="dsq-comment-message-2163" class="dsq-comment-message"><p>#vimctimized</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2172">
        <div id="dsq-comment-header-2172" class="dsq-comment-header">
            <cite id="dsq-cite-2172">
                <span id="dsq-author-user-2172">Luís Muniz</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2172" class="dsq-comment-body">
            <div id="dsq-comment-message-2172" class="dsq-comment-message"><p>LOL!</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-2171">
        <div id="dsq-comment-header-2171" class="dsq-comment-header">
            <cite id="dsq-cite-2171">
                <span id="dsq-author-user-2171">S Stewart</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2171" class="dsq-comment-body">
            <div id="dsq-comment-message-2171" class="dsq-comment-message"><p>I&#8217;m surprised the US or UK doesn&#8217;t get stuck very much to be honest.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even thread-even depth-1" id="dsq-comment-2174">
        <div id="dsq-comment-header-2174" class="dsq-comment-header">
            <cite id="dsq-cite-2174">
                <span id="dsq-author-user-2174">jim lesperance</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2174" class="dsq-comment-body">
            <div id="dsq-comment-message-2174" class="dsq-comment-message"><p>quick way to exit of vim &#8220;`SHIFT q + q&#8220;`</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2182">
        <div id="dsq-comment-header-2182" class="dsq-comment-header">
            <cite id="dsq-cite-2182">
                <span id="dsq-author-user-2182">Haures</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2182" class="dsq-comment-body">
            <div id="dsq-comment-message-2182" class="dsq-comment-message"><p>Triple single quotes, you bastard!</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-3" id="dsq-comment-2192">
        <div id="dsq-comment-header-2192" class="dsq-comment-header">
            <cite id="dsq-cite-2192">
                <span id="dsq-author-user-2192">jim lesperance</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2192" class="dsq-comment-body">
            <div id="dsq-comment-message-2192" class="dsq-comment-message"><p>my mistake  it&#8217;s not quotes its  markdown back-ticks</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-3" id="dsq-comment-2212">
        <div id="dsq-comment-header-2212" class="dsq-comment-header">
            <cite id="dsq-cite-2212">
                <span id="dsq-author-user-2212">jim lesperance</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2212" class="dsq-comment-body">
            <div id="dsq-comment-message-2212" class="dsq-comment-message"><p>my mistacke its not quotes its backticks</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2175">
        <div id="dsq-comment-header-2175" class="dsq-comment-header">
            <cite id="dsq-cite-2175">
                <span id="dsq-author-user-2175">Schwechater</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2175" class="dsq-comment-body">
            <div id="dsq-comment-message-2175" class="dsq-comment-message"><p>If you&#8217;re still using Vim to code (instead of a modern IDE) you&#8217;re a. incredibly old b. incredibly good c. incredibly stupid or d. an incredible hipster.<br />
My guess is it&#8217;s 4% a &amp; b and 96% c &amp; d.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2180">
        <div id="dsq-comment-header-2180" class="dsq-comment-header">
            <cite id="dsq-cite-2180">
                <span id="dsq-author-user-2180">Mark Anderson</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2180" class="dsq-comment-body">
            <div id="dsq-comment-message-2180" class="dsq-comment-message"><p>You forgot e. All of the Above</p>
<p>But to be honest I wind up using it for sysadmin tasks quite a bit. You always know vi will be there.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2183">
        <div id="dsq-comment-header-2183" class="dsq-comment-header">
            <cite id="dsq-cite-2183">
                <span id="dsq-author-user-2183">Bernd Paysan</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2183" class="dsq-comment-body">
            <div id="dsq-comment-message-2183" class="dsq-comment-message"><p>That&#8217;s vimctim blaming!</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2185">
        <div id="dsq-comment-header-2185" class="dsq-comment-header">
            <cite id="dsq-cite-2185">
                <span id="dsq-author-user-2185">Néstor Espinoza</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2185" class="dsq-comment-body">
            <div id="dsq-comment-message-2185" class="dsq-comment-message"><p>You forgot e. lazy to learn another IDE. I&#8217;m 100% that one.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2186">
        <div id="dsq-comment-header-2186" class="dsq-comment-header">
            <cite id="dsq-cite-2186">
                <span id="dsq-author-user-2186">Koen Dejonghe</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2186" class="dsq-comment-body">
            <div id="dsq-comment-message-2186" class="dsq-comment-message"><p>I use the VIM plugin in IntelliJ for Scala and all other development. It&#8217;s bliss.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2198">
        <div id="dsq-comment-header-2198" class="dsq-comment-header">
            <cite id="dsq-cite-2198">
                <span id="dsq-author-user-2198">Donkey Puncherello</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2198" class="dsq-comment-body">
            <div id="dsq-comment-message-2198" class="dsq-comment-message"><p>This guy got stuck in VIM</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2209">
        <div id="dsq-comment-header-2209" class="dsq-comment-header">
            <cite id="dsq-cite-2209">
                <span id="dsq-author-user-2209">a_horse</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2209" class="dsq-comment-body">
            <div id="dsq-comment-message-2209" class="dsq-comment-message"><p>phenomenal tactic to stick that &#8220;incredibly good&#8221; in there so that folk like me can&#8217;t quite justify a downvote</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2211">
        <div id="dsq-comment-header-2211" class="dsq-comment-header">
            <cite id="dsq-cite-2211">
                <span id="dsq-author-user-2211">Martin</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2211" class="dsq-comment-body">
            <div id="dsq-comment-message-2211" class="dsq-comment-message"><p>What about Haskellers? It&#8217;s  kind of the best Haskell ide with all the plugins. Although Atom is nooice for the job too.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2218">
        <div id="dsq-comment-header-2218" class="dsq-comment-header">
            <cite id="dsq-cite-2218">
                <span id="dsq-author-user-2218">Xiong Chiamiov</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2218" class="dsq-comment-body">
            <div id="dsq-comment-message-2218" class="dsq-comment-message"><p>I use vim because I&#8217;m an SRE, so I spend a lot of time working on various remote servers (often through several ssh chains).  There&#8217;s really no good option other than a terminal-based editor for this, and if I&#8217;m going to spend a lot of time polishing my use of that toolset, I might as well use it the 20% of the time I&#8217;m local as well.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2230">
        <div id="dsq-comment-header-2230" class="dsq-comment-header">
            <cite id="dsq-cite-2230">
                <span id="dsq-author-user-2230">alavers</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2230" class="dsq-comment-body">
            <div id="dsq-comment-message-2230" class="dsq-comment-message"><p>vim *is* a modern IDE 😉</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2232">
        <div id="dsq-comment-header-2232" class="dsq-comment-header">
            <cite id="dsq-cite-2232">
                <span id="dsq-author-user-2232">Chris Myers</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2232" class="dsq-comment-body">
            <div id="dsq-comment-message-2232" class="dsq-comment-message"><p>e) all of the above</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2291">
        <div id="dsq-comment-header-2291" class="dsq-comment-header">
            <cite id="dsq-cite-2291">
                <span id="dsq-author-user-2291">MaxSchumacher</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2291" class="dsq-comment-body">
            <div id="dsq-comment-message-2291" class="dsq-comment-message"><p>never used an editor with better shortcuts</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-even depth-1" id="dsq-comment-2187">
        <div id="dsq-comment-header-2187" class="dsq-comment-header">
            <cite id="dsq-cite-2187">
                <span id="dsq-author-user-2187">Eion Robb</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2187" class="dsq-comment-body">
            <div id="dsq-comment-message-2187" class="dsq-comment-message"><p>Great post!</p>
<p>:quit<br />
<a href="http://www.google.com" rel="nofollow">http://www.google.com</a><br />
how to exit comment<br />
help<br />
escape<br />
escape<br />
:quit<br />
:quit</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-2188">
        <div id="dsq-comment-header-2188" class="dsq-comment-header">
            <cite id="dsq-cite-2188">
                <a id="dsq-author-user-2188" href="http://jsroyal.github.io" target="_blank" rel="nofollow">jsroyal</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2188" class="dsq-comment-body">
            <div id="dsq-comment-message-2188" class="dsq-comment-message"><p>Sublime to Intellij.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even thread-even depth-1" id="dsq-comment-2189">
        <div id="dsq-comment-header-2189" class="dsq-comment-header">
            <cite id="dsq-cite-2189">
                <span id="dsq-author-user-2189">Mr. Xcoder</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2189" class="dsq-comment-body">
            <div id="dsq-comment-message-2189" class="dsq-comment-message"><p>I did&#8217;t know 2015, 2016, &#8230; are months. <a href="https://uploads.disquscdn.com/images/331b453e9dfe3ea91460b73c1bdbeac5e3b974f4e1798aab9b714ac075d0a5a8.png" rel="nofollow">https://uploads.disquscdn.com/images/331b453e9dfe3ea91460b73c1bdbeac5e3b974f4e1798aab9b714ac075d0a5a8.png</a></p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2199">
        <div id="dsq-comment-header-2199" class="dsq-comment-header">
            <cite id="dsq-cite-2199">
                <span id="dsq-author-user-2199">aaronchall</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2199" class="dsq-comment-body">
            <div id="dsq-comment-message-2199" class="dsq-comment-message"><p>Each data point seems to be a month, but if they showed months in the ticks, I don&#8217;t think they&#8217;d be readable.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2191">
        <div id="dsq-comment-header-2191" class="dsq-comment-header">
            <cite id="dsq-cite-2191">
                <a id="dsq-author-user-2191" href="https://twitter.com/YannDinendal" target="_blank" rel="nofollow">Yann Dìnendal</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2191" class="dsq-comment-body">
            <div id="dsq-comment-message-2191" class="dsq-comment-message"><p>Quickest way to quit vim: `Ctrl+z`. 😁</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2194">
        <div id="dsq-comment-header-2194" class="dsq-comment-header">
            <cite id="dsq-cite-2194">
                <span id="dsq-author-user-2194">warren5236</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2194" class="dsq-comment-body">
            <div id="dsq-comment-message-2194" class="dsq-comment-message"><p>Then a quick reboot to remove the process.  🙂</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2206">
        <div id="dsq-comment-header-2206" class="dsq-comment-header">
            <cite id="dsq-cite-2206">
                <span id="dsq-author-user-2206">Matias Fernandez</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2206" class="dsq-comment-body">
            <div id="dsq-comment-message-2206" class="dsq-comment-message"><p>Ctrl+z<br />
kill -9 %%</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2193">
        <div id="dsq-comment-header-2193" class="dsq-comment-header">
            <cite id="dsq-cite-2193">
                <span id="dsq-author-user-2193">Matt Gracie</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2193" class="dsq-comment-body">
            <div id="dsq-comment-message-2193" class="dsq-comment-message"><p>Neophytes don&#8217;t understand that Vim has two modes: there&#8217;s &#8220;beep mode&#8221;, where any character just rings the terminal bell, and there&#8217;s &#8220;nothing mode&#8221;, where keys don&#8217;t seem to do anything at all.</p>
<p>Hope that helps!</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2248">
        <div id="dsq-comment-header-2248" class="dsq-comment-header">
            <cite id="dsq-cite-2248">
                <a id="dsq-author-user-2248" href="http://ralphembree.blg.lt" target="_blank" rel="nofollow">Ralph Embree</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2248" class="dsq-comment-body">
            <div id="dsq-comment-message-2248" class="dsq-comment-message"><p>In my experience, not knowing how to use Vim results in a bunch of unexpected things, not nothing at all. What do you call that mode?</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-2195">
        <div id="dsq-comment-header-2195" class="dsq-comment-header">
            <cite id="dsq-cite-2195">
                <span id="dsq-author-user-2195">Hoppinglife</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2195" class="dsq-comment-body">
            <div id="dsq-comment-message-2195" class="dsq-comment-message"><p>One explanation for the lack of traffic from China could be self-selection &#8211; users from China have to penetrate language and often a firewall barrier to visit stack overflow, it&#8217;s possible that they are more experienced in general.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2213">
        <div id="dsq-comment-header-2213" class="dsq-comment-header">
            <cite id="dsq-cite-2213">
                <span id="dsq-author-user-2213">lowatt</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2213" class="dsq-comment-body">
            <div id="dsq-comment-message-2213" class="dsq-comment-message"><p>AFAIK, 1) stackoverflow is not banned in China at least for the past 5 years.  2) Most Chinese developers learn English since junior high school (7 grade). We need more data like &#8216;total number of visitors from each country&#8217; to better explain it other than blindly guessing.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2233">
        <div id="dsq-comment-header-2233" class="dsq-comment-header">
            <cite id="dsq-cite-2233">
                <span id="dsq-author-user-2233">MrHublot</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2233" class="dsq-comment-body">
            <div id="dsq-comment-message-2233" class="dsq-comment-message"><p>As a Chinese engineer who currently works in US, I believe it&#8217;s because:<br />
1) developers are not comfortable talking/thinking in English even tho most of them started learning English since young ages.<br />
2) searching English contents using Baidu is a pain in the ass. It&#8217;s horrible. Nobody wants to do it. Besides, you can find the same answers to the same questions in Chinese fairly easy. So no traffic from these people to SO at all.<br />
3) People who do have the English skills and need for answers of more complicated questions will def use SO. But then again, those are very unlikely click on questions such as &#8216;how to quit vim&#8217;.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-even depth-1" id="dsq-comment-2203">
        <div id="dsq-comment-header-2203" class="dsq-comment-header">
            <cite id="dsq-cite-2203">
                <span id="dsq-author-user-2203">Toni Lähdekorpi</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2203" class="dsq-comment-body">
            <div id="dsq-comment-message-2203" class="dsq-comment-message"><p>^C^C^[^[^C^Z^[qqQ!qQ^C:q^C^C^[exit^Cquit^[^[:quit^C^C^C^[^C^C^[[3~^[[3~qqqqqqfqqffuuuuck</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-2207">
        <div id="dsq-comment-header-2207" class="dsq-comment-header">
            <cite id="dsq-cite-2207">
                <span id="dsq-author-user-2207">TerryGauchat</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2207" class="dsq-comment-body">
            <div id="dsq-comment-message-2207" class="dsq-comment-message"><p>Ukraine based criminal hackers should not be assisted in configuring malware. How about telling them to go fornicate themselves? (Ukraine is the #1 source of all malicious attacks against WordPress and other websites over the past year or two).</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2214">
        <div id="dsq-comment-header-2214" class="dsq-comment-header">
            <cite id="dsq-cite-2214">
                <a id="dsq-author-user-2214" href="http://marcogomes.com/" target="_blank" rel="nofollow">marcogomes</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2214" class="dsq-comment-body">
            <div id="dsq-comment-message-2214" class="dsq-comment-message"><p>The criminal hackers do their crimes without at least a VPN tunneling them to some other country?</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2219">
        <div id="dsq-comment-header-2219" class="dsq-comment-header">
            <cite id="dsq-cite-2219">
                <span id="dsq-author-user-2219">TerryGauchat</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2219" class="dsq-comment-body">
            <div id="dsq-comment-message-2219" class="dsq-comment-message"><p>Perhaps, but:<br />
1. A lot of these criminals are not sophisticated. They are just contracted by larger organizations to distribute malware. They use vim to set up configuration files.</p>
<p>2. If Ukraine is hosting VPN providers for these individuals and organizations, then they are culpable accessories to crime.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-4" id="dsq-comment-2246">
        <div id="dsq-comment-header-2246" class="dsq-comment-header">
            <cite id="dsq-cite-2246">
                <a id="dsq-author-user-2246" href="http://ralphembree.blg.lt" target="_blank" rel="nofollow">Ralph Embree</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2246" class="dsq-comment-body">
            <div id="dsq-comment-message-2246" class="dsq-comment-message"><p>They use Vim to set up configuration files, but they don&#8217;t know how to use it?</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-5" id="dsq-comment-2250">
        <div id="dsq-comment-header-2250" class="dsq-comment-header">
            <cite id="dsq-cite-2250">
                <span id="dsq-author-user-2250">TerryGauchat</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2250" class="dsq-comment-body">
            <div id="dsq-comment-message-2250" class="dsq-comment-message"><p>Doh! That&#8217;s the whole point of this Article. Apparently thousands of vim users do not know how to &#8220;exit vim&#8221;. And yes&#8230; I can fully believe that thousands of people in Eastern Europe are joining the criminal hacker &#8220;industry&#8221; with minimal computer skills &#8230; including needing to learn &#8220;how to exit vim&#8221;.  This is just a theory as to why the traffic for that query is so high from Ukraine. There is obviously a correlation; but not proof.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-5" id="dsq-comment-2254">
        <div id="dsq-comment-header-2254" class="dsq-comment-header">
            <cite id="dsq-cite-2254">
                <a id="dsq-author-user-2254" href="http://ralphembree.blg.lt" target="_blank" rel="nofollow">Ralph Embree</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2254" class="dsq-comment-body">
            <div id="dsq-comment-message-2254" class="dsq-comment-message"><p>I realize that&#8217;s the point of the article, which is why I brought it up. If they don&#8217;t know how to use Vim, they probably don&#8217;t use it for their configuration files. It&#8217;s most likely for something they don&#8217;t do very often.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-5" id="dsq-comment-2256">
        <div id="dsq-comment-header-2256" class="dsq-comment-header">
            <cite id="dsq-cite-2256">
                <span id="dsq-author-user-2256">EE</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2256" class="dsq-comment-body">
            <div id="dsq-comment-message-2256" class="dsq-comment-message"><p>The question may be curiosity-driven. In Eastern Europe, such things as VIM are fascinating, but we&#8217;re rarely interested enough to get systematic knowledge of them.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2215">
        <div id="dsq-comment-header-2215" class="dsq-comment-header">
            <cite id="dsq-cite-2215">
                <span id="dsq-author-user-2215">Thor Heyerdahl</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2215" class="dsq-comment-body">
            <div id="dsq-comment-message-2215" class="dsq-comment-message"><p>I&#8217;d say front-end developers stuck in Vim are quite unlikely to be malicious hackers.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2220">
        <div id="dsq-comment-header-2220" class="dsq-comment-header">
            <cite id="dsq-cite-2220">
                <span id="dsq-author-user-2220">TerryGauchat</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2220" class="dsq-comment-body">
            <div id="dsq-comment-message-2220" class="dsq-comment-message"><p>A lot of these criminals are not sophisticated. They are just contracted by larger organizations to distribute malware. They are told to use vim to set up configuration files.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2275">
        <div id="dsq-comment-header-2275" class="dsq-comment-header">
            <cite id="dsq-cite-2275">
                <span id="dsq-author-user-2275">NoobLance</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2275" class="dsq-comment-body">
            <div id="dsq-comment-message-2275" class="dsq-comment-message"><p>Are you suggesting we deny millions of people an answer because hackers use vim? lol</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2516">
        <div id="dsq-comment-header-2516" class="dsq-comment-header">
            <cite id="dsq-cite-2516">
                <span id="dsq-author-user-2516">ollieclark</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2516" class="dsq-comment-body">
            <div id="dsq-comment-message-2516" class="dsq-comment-message"><p>Hackers use computers. By your logic, no one should answer any computer questions because it would help hackers.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-even depth-1" id="dsq-comment-2210">
        <div id="dsq-comment-header-2210" class="dsq-comment-header">
            <cite id="dsq-cite-2210">
                <span id="dsq-author-user-2210">Charles Wolfe</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2210" class="dsq-comment-body">
            <div id="dsq-comment-message-2210" class="dsq-comment-message"><p>Habitually I press ESCAPE then :wq!  kids these day, geeze</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2216">
        <div id="dsq-comment-header-2216" class="dsq-comment-header">
            <cite id="dsq-cite-2216">
                <span id="dsq-author-user-2216">David</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2216" class="dsq-comment-body">
            <div id="dsq-comment-message-2216" class="dsq-comment-message"><p>you should be using :x!<br />
It saves a key stroke.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-3" id="dsq-comment-2222">
        <div id="dsq-comment-header-2222" class="dsq-comment-header">
            <cite id="dsq-cite-2222">
                <span id="dsq-author-user-2222">Random832</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2222" class="dsq-comment-body">
            <div id="dsq-comment-message-2222" class="dsq-comment-message"><p>ZZ</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-3" id="dsq-comment-2225">
        <div id="dsq-comment-header-2225" class="dsq-comment-header">
            <cite id="dsq-cite-2225">
                <span id="dsq-author-user-2225">Iván Castellanos</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2225" class="dsq-comment-body">
            <div id="dsq-comment-message-2225" class="dsq-comment-message"><p>Don&#8217;t use VIM at all, it saves ALL the keystrokes</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-3" id="dsq-comment-2237">
        <div id="dsq-comment-header-2237" class="dsq-comment-header">
            <cite id="dsq-cite-2237">
                <span id="dsq-author-user-2237">Kurt Mueller</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2237" class="dsq-comment-body">
            <div id="dsq-comment-message-2237" class="dsq-comment-message"><p>Could also do just :q!</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2334">
        <div id="dsq-comment-header-2334" class="dsq-comment-header">
            <cite id="dsq-cite-2334">
                <a id="dsq-author-user-2334" href="http://meta.stackexchange.com/users/155160" target="_blank" rel="nofollow">Adam Lear</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2334" class="dsq-comment-body">
            <div id="dsq-comment-message-2334" class="dsq-comment-message"><p>Escape, then save and quit kids? That sounds like a handy trick for outings to family restaurants. =)</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2217">
        <div id="dsq-comment-header-2217" class="dsq-comment-header">
            <cite id="dsq-cite-2217">
                <span id="dsq-author-user-2217">Léo Martin</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2217" class="dsq-comment-body">
            <div id="dsq-comment-message-2217" class="dsq-comment-message"><p>Vim and Bc are too good for SIGINT</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2223">
        <div id="dsq-comment-header-2223" class="dsq-comment-header">
            <cite id="dsq-cite-2223">
                <a id="dsq-author-user-2223" href="http://www.cryptologie.net/" target="_blank" rel="nofollow">mimoo</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2223" class="dsq-comment-body">
            <div id="dsq-comment-message-2223" class="dsq-comment-message"><p>We&#8217;ve all been stuck inside vim at least once in our life.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2226">
        <div id="dsq-comment-header-2226" class="dsq-comment-header">
            <cite id="dsq-cite-2226">
                <span id="dsq-author-user-2226">Tomás Castro López</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2226" class="dsq-comment-body">
            <div id="dsq-comment-message-2226" class="dsq-comment-message"><p>:! sudo rm -rf /</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2228">
        <div id="dsq-comment-header-2228" class="dsq-comment-header">
            <cite id="dsq-cite-2228">
                <span id="dsq-author-user-2228">Chris Myers</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2228" class="dsq-comment-body">
            <div id="dsq-comment-message-2228" class="dsq-comment-message"><p>pure evil</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-3" id="dsq-comment-2240">
        <div id="dsq-comment-header-2240" class="dsq-comment-header">
            <cite id="dsq-cite-2240">
                <span id="dsq-author-user-2240">ProgrammingNewbie .</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2240" class="dsq-comment-body">
            <div id="dsq-comment-message-2240" class="dsq-comment-message"><p>pretty much, who takes joy out of that? There might be noobs reading this&#8230;.fucked up</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2229">
        <div id="dsq-comment-header-2229" class="dsq-comment-header">
            <cite id="dsq-cite-2229">
                <span id="dsq-author-user-2229">Drop Message</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2229" class="dsq-comment-body">
            <div id="dsq-comment-message-2229" class="dsq-comment-message"><p>Getting out of Vim is easy. Getting stuck in ex mode is where the true depths of hell lie!</p>
<p>Also: I love that this page is a thing which exists. Just what my day needed.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2258">
        <div id="dsq-comment-header-2258" class="dsq-comment-header">
            <cite id="dsq-cite-2258">
                <span id="dsq-author-user-2258">Gabriel Laughlin</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2258" class="dsq-comment-body">
            <div id="dsq-comment-message-2258" class="dsq-comment-message"><p>Or when you start pressing buttons and find yourself in &#8216;recording&#8217; mode, whatever that is. I usually just restart my computer haha.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2268">
        <div id="dsq-comment-header-2268" class="dsq-comment-header">
            <cite id="dsq-cite-2268">
                <span id="dsq-author-user-2268">Drop Message</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2268" class="dsq-comment-body">
            <div id="dsq-comment-message-2268" class="dsq-comment-message"><p>Haha, I feel your pain, but once you find out what it is, it&#8217;s actually very useful, I promise!</p>
<p>It records one&#8217;s keystrokes into macros. It&#8217;s really handy for when you have some repetitive task that&#8217;s not quite worthy of running through a shell script or somesuch.</p>
<p>Still, even as somebody who&#8217;s reasonably well-versed in Vim, I occasionally find myself accidentally enabling it and getting annoyed. 😀</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-3" id="dsq-comment-2271">
        <div id="dsq-comment-header-2271" class="dsq-comment-header">
            <cite id="dsq-cite-2271">
                <span id="dsq-author-user-2271">Julio Bastida</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2271" class="dsq-comment-body">
            <div id="dsq-comment-message-2271" class="dsq-comment-message"><p>The hell man! recording mode lets you crate macros, macros are one of the reasons vim beat the shit out of &#8220;advances editors&#8221; like sublime text or other ides</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-2231">
        <div id="dsq-comment-header-2231" class="dsq-comment-header">
            <cite id="dsq-cite-2231">
                <span id="dsq-author-user-2231">Albert Gomis Verdu</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2231" class="dsq-comment-body">
            <div id="dsq-comment-message-2231" class="dsq-comment-message"><p>what&#8217;s wrong with nano?</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2234">
        <div id="dsq-comment-header-2234" class="dsq-comment-header">
            <cite id="dsq-cite-2234">
                <a id="dsq-author-user-2234" href="http://riddi.eu" target="_blank" rel="nofollow">Gen Lee</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2234" class="dsq-comment-body">
            <div id="dsq-comment-message-2234" class="dsq-comment-message"><p>everything</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2242">
        <div id="dsq-comment-header-2242" class="dsq-comment-header">
            <cite id="dsq-cite-2242">
                <span id="dsq-author-user-2242">Graham Harwood</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2242" class="dsq-comment-body">
            <div id="dsq-comment-message-2242" class="dsq-comment-message"><p>How much time do you have?</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2264">
        <div id="dsq-comment-header-2264" class="dsq-comment-header">
            <cite id="dsq-cite-2264">
                <span id="dsq-author-user-2264">Jacob Lindquist</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2264" class="dsq-comment-body">
            <div id="dsq-comment-message-2264" class="dsq-comment-message"><p>It&#8217;s not Pico</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2272">
        <div id="dsq-comment-header-2272" class="dsq-comment-header">
            <cite id="dsq-cite-2272">
                <span id="dsq-author-user-2272">ThiefMaster</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2272" class="dsq-comment-body">
            <div id="dsq-comment-message-2272" class="dsq-comment-message"><p>lack of syntax highlighting for a starter. and the annoying confirmation prompt of the filename when saving an edit to an existing file (dunno if you can disable that)</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-3" id="dsq-comment-2274">
        <div id="dsq-comment-header-2274" class="dsq-comment-header">
            <cite id="dsq-cite-2274">
                <span id="dsq-author-user-2274">Benjamin Babik</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2274" class="dsq-comment-body">
            <div id="dsq-comment-message-2274" class="dsq-comment-message"><p>It has syntax highlighting</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-3" id="dsq-comment-2285">
        <div id="dsq-comment-header-2285" class="dsq-comment-header">
            <cite id="dsq-cite-2285">
                <span id="dsq-author-user-2285">Matthew</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2285" class="dsq-comment-body">
            <div id="dsq-comment-message-2285" class="dsq-comment-message"><p>@ThiefMaster:disqus , nano has syntax highlighting for those that need it.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2279">
        <div id="dsq-comment-header-2279" class="dsq-comment-header">
            <cite id="dsq-cite-2279">
                <a id="dsq-author-user-2279" href="http://timothy.green.name/" target="_blank" rel="nofollow">Timothy (TRiG)</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2279" class="dsq-comment-body">
            <div id="dsq-comment-message-2279" class="dsq-comment-message"><p>Nano is quick and easy, and perfect for my purposes, but I could well believe that vim has far greater functionality for those who wish to learn it.</p>
<p>TRiG.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2284">
        <div id="dsq-comment-header-2284" class="dsq-comment-header">
            <cite id="dsq-cite-2284">
                <span id="dsq-author-user-2284">Matthew</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2284" class="dsq-comment-body">
            <div id="dsq-comment-message-2284" class="dsq-comment-message"><p>There&#8217;s absolutely nothing wrong with nano @albertgomisverdu:disqus ! I love it and have been using it since mid 2000s. nano is super simple without the complexity of vi.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2320">
        <div id="dsq-comment-header-2320" class="dsq-comment-header">
            <cite id="dsq-cite-2320">
                <span id="dsq-author-user-2320">Thuglas Nasty</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2320" class="dsq-comment-body">
            <div id="dsq-comment-message-2320" class="dsq-comment-message"><p>what&#8217;s wrong with pico?</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2236">
        <div id="dsq-comment-header-2236" class="dsq-comment-header">
            <cite id="dsq-cite-2236">
                <span id="dsq-author-user-2236">AzSandrat</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2236" class="dsq-comment-body">
            <div id="dsq-comment-message-2236" class="dsq-comment-message"><p>:wq</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2238">
        <div id="dsq-comment-header-2238" class="dsq-comment-header">
            <cite id="dsq-cite-2238">
                <span id="dsq-author-user-2238">and then some</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2238" class="dsq-comment-body">
            <div id="dsq-comment-message-2238" class="dsq-comment-message"><p>What if you don&#8217;t want to save your changes? :colbert:</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2241">
        <div id="dsq-comment-header-2241" class="dsq-comment-header">
            <cite id="dsq-cite-2241">
                <span id="dsq-author-user-2241">sergeydgr8</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2241" class="dsq-comment-body">
            <div id="dsq-comment-message-2241" class="dsq-comment-message"><p>:q!</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-4" id="dsq-comment-2261">
        <div id="dsq-comment-header-2261" class="dsq-comment-header">
            <cite id="dsq-cite-2261">
                <span id="dsq-author-user-2261">and then some</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2261" class="dsq-comment-body">
            <div id="dsq-comment-message-2261" class="dsq-comment-message"><p>Yeesh, no need to get uppity about it! 😉</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-4" id="dsq-comment-2273">
        <div id="dsq-comment-header-2273" class="dsq-comment-header">
            <cite id="dsq-cite-2273">
                <span id="dsq-author-user-2273">Puns ponies podcasts</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2273" class="dsq-comment-body">
            <div id="dsq-comment-message-2273" class="dsq-comment-message"><p>Well just typing smileys won&#8217;t help!</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even depth-3" id="dsq-comment-2243">
        <div id="dsq-comment-header-2243" class="dsq-comment-header">
            <cite id="dsq-cite-2243">
                <span id="dsq-author-user-2243">Drop Message</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2243" class="dsq-comment-body">
            <div id="dsq-comment-message-2243" class="dsq-comment-message"><p>Just FYI:</p>
<p><code>E492: Not an editor command: colbert:</code></p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2289">
        <div id="dsq-comment-header-2289" class="dsq-comment-header">
            <cite id="dsq-cite-2289">
                <span id="dsq-author-user-2289">MaxSchumacher</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2289" class="dsq-comment-body">
            <div id="dsq-comment-message-2289" class="dsq-comment-message"><p>😡 is shorter</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2244">
        <div id="dsq-comment-header-2244" class="dsq-comment-header">
            <cite id="dsq-cite-2244">
                <span id="dsq-author-user-2244">the root</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2244" class="dsq-comment-body">
            <div id="dsq-comment-message-2244" class="dsq-comment-message"><p>open a new shell; killall vim</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2265">
        <div id="dsq-comment-header-2265" class="dsq-comment-header">
            <cite id="dsq-cite-2265">
                <span id="dsq-author-user-2265">Eugene Naydenov</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2265" class="dsq-comment-body">
            <div id="dsq-comment-message-2265" class="dsq-comment-message"><p>But more reliable is to execute `reboot` in a new shell. 😀</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-even depth-1" id="dsq-comment-2247">
        <div id="dsq-comment-header-2247" class="dsq-comment-header">
            <cite id="dsq-cite-2247">
                <span id="dsq-author-user-2247">Santiago</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2247" class="dsq-comment-body">
            <div id="dsq-comment-message-2247" class="dsq-comment-message"><p>I have more trouble exiting nano</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2255">
        <div id="dsq-comment-header-2255" class="dsq-comment-header">
            <cite id="dsq-cite-2255">
                <span id="dsq-author-user-2255">HappyzLife</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2255" class="dsq-comment-body">
            <div id="dsq-comment-message-2255" class="dsq-comment-message"><p>ctrl + o<br />
ctrl + x</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2260">
        <div id="dsq-comment-header-2260" class="dsq-comment-header">
            <cite id="dsq-cite-2260">
                <span id="dsq-author-user-2260">bit2shift</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2260" class="dsq-comment-body">
            <div id="dsq-comment-message-2260" class="dsq-comment-message"><p>nano is even kind enough to constantly show you some help.<br />
<a href="https://uploads.disquscdn.com/images/c0ae645c16a93b8a4944b58514b7aeb06445772ade68991972353ae28c540460.png" rel="nofollow">https://uploads.disquscdn.com/images/c0ae645c16a93b8a4944b58514b7aeb06445772ade68991972353ae28c540460.png</a></p>
<p>PS: Now, if you&#8217;re unfamiliar with the &#8220;^letter&#8221; prefix, that stands for ctrl + letter.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2297">
        <div id="dsq-comment-header-2297" class="dsq-comment-header">
            <cite id="dsq-cite-2297">
                <a id="dsq-author-user-2297" href="https://www.mos3abof.com/" target="_blank" rel="nofollow">Mosab Ibrahim</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2297" class="dsq-comment-body">
            <div id="dsq-comment-message-2297" class="dsq-comment-message"><p>I get seriously disturbed every time I see nano set to the default editor on a server. I can&#8217;t agree more with you.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2249">
        <div id="dsq-comment-header-2249" class="dsq-comment-header">
            <cite id="dsq-cite-2249">
                <span id="dsq-author-user-2249">Odd Dahl</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2249" class="dsq-comment-body">
            <div id="dsq-comment-message-2249" class="dsq-comment-message"><p>The hell when you forget to add a commit message to your commit&#8230; wooh.. git has some shitty ways of doing stuff</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2252">
        <div id="dsq-comment-header-2252" class="dsq-comment-header">
            <cite id="dsq-cite-2252">
                <span id="dsq-author-user-2252">Eric Zeller</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2252" class="dsq-comment-body">
            <div id="dsq-comment-message-2252" class="dsq-comment-message"><p>For me vi/vim is easy  &#8211; it&#8217;s second nature&#8230;<br />
I can&#8217;t say how many times I&#8217;ve typed ZZ into notepad though&#8230;.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2269">
        <div id="dsq-comment-header-2269" class="dsq-comment-header">
            <cite id="dsq-cite-2269">
                <span id="dsq-author-user-2269">Drop Message</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2269" class="dsq-comment-body">
            <div id="dsq-comment-message-2269" class="dsq-comment-message"><p>I frequently accidentally enter characters in other editors, text fields etc. when my muscle memory thinks it&#8217;s in command Vim&#8217;s command mode.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2270">
        <div id="dsq-comment-header-2270" class="dsq-comment-header">
            <cite id="dsq-cite-2270">
                <span id="dsq-author-user-2270">kchassa</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2270" class="dsq-comment-body">
            <div id="dsq-comment-message-2270" class="dsq-comment-message"><p>No so on notepad, notepad++ etc&#8230; all text editor I have typed esc : x! lololol</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2253">
        <div id="dsq-comment-header-2253" class="dsq-comment-header">
            <cite id="dsq-cite-2253">
                <span id="dsq-author-user-2253">Aldo Fregoso</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2253" class="dsq-comment-body">
            <div id="dsq-comment-message-2253" class="dsq-comment-message"><p>&gt; That might indicate that when developers in these countries enter Vim, they usually meant to do so, and they know how to get out of it.</p>
<p>I don&#8217;t know, maybe they&#8217;re more likely to write &#8220;如何退出vim?&#8221;</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2262">
        <div id="dsq-comment-header-2262" class="dsq-comment-header">
            <cite id="dsq-cite-2262">
                <span id="dsq-author-user-2262">Shane Xie</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2262" class="dsq-comment-body">
            <div id="dsq-comment-message-2262" class="dsq-comment-message"><p>or they don&#8217;t even use SO.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-3" id="dsq-comment-2263">
        <div id="dsq-comment-header-2263" class="dsq-comment-header">
            <cite id="dsq-cite-2263">
                <span id="dsq-author-user-2263">Milutin</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2263" class="dsq-comment-body">
            <div id="dsq-comment-message-2263" class="dsq-comment-message"><p>considering the population density, chances are that there&#8217;s someone near who knows how to exit 😛</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-4" id="dsq-comment-2276">
        <div id="dsq-comment-header-2276" class="dsq-comment-header">
            <cite id="dsq-cite-2276">
                <span id="dsq-author-user-2276">Fredrik Edin</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2276" class="dsq-comment-body">
            <div id="dsq-comment-message-2276" class="dsq-comment-message"><p>You guys should read up on stats &#8230; Of all the Chinese vim questions, only 0.4% were related to exiting. Doesn&#8217;t matter the population density or what have you&#8230;</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-5" id="dsq-comment-2290">
        <div id="dsq-comment-header-2290" class="dsq-comment-header">
            <cite id="dsq-cite-2290">
                <span id="dsq-author-user-2290">Taylor Moore</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2290" class="dsq-comment-body">
            <div id="dsq-comment-message-2290" class="dsq-comment-message"><p>I think he was saying that there&#8217;s someone sitting nearby to verbally ask.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-5" id="dsq-comment-2469">
        <div id="dsq-comment-header-2469" class="dsq-comment-header">
            <cite id="dsq-cite-2469">
                <span id="dsq-author-user-2469">Milutin</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2469" class="dsq-comment-body">
            <div id="dsq-comment-message-2469" class="dsq-comment-message"><p>1. it was a joke<br />
2. you should re-read my answer, think about it and see that i&#8217;m right 🙂</p>
<p>namely, there are X vim searchers in china and let&#8217;s say 90% of them are exit related. however, with my comment above, those 90% fall of&#8230; so only 10% of users actually become real SO registered vim searchers. obviously, since 90% of exit users got their answers in real life, only small % of them actually search for EXIT help.</p>
<p>this also could mean that china vim users are only good at exiting vim 🙂 but that&#8217;s totally different story.</p>
<p>p.s. stop being a wiseas* 🙂</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-even depth-1" id="dsq-comment-2277">
        <div id="dsq-comment-header-2277" class="dsq-comment-header">
            <cite id="dsq-cite-2277">
                <span id="dsq-author-user-2277">Mart</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2277" class="dsq-comment-body">
            <div id="dsq-comment-message-2277" class="dsq-comment-message"><p>What about how to exit emacs?</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2278">
        <div id="dsq-comment-header-2278" class="dsq-comment-header">
            <cite id="dsq-cite-2278">
                <a id="dsq-author-user-2278" href="http://thomasspear.name/" target="_blank" rel="nofollow">Thomas Spear</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2278" class="dsq-comment-body">
            <div id="dsq-comment-message-2278" class="dsq-comment-message"><p>Emacs isn&#8217;t the default &#8220;`$EDITOR&#8220;` in most environments so git probably didn&#8217;t contribute to it&#8217;s views the way git contributes to this question&#8217;s views.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2283">
        <div id="dsq-comment-header-2283" class="dsq-comment-header">
            <cite id="dsq-cite-2283">
                <span id="dsq-author-user-2283">commenter</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2283" class="dsq-comment-body">
            <div id="dsq-comment-message-2283" class="dsq-comment-message"><p>At least most of us have no problems starting vim 😉 Can&#8217;t remember if I ever managed to start emacs 😀</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2287">
        <div id="dsq-comment-header-2287" class="dsq-comment-header">
            <cite id="dsq-cite-2287">
                <span id="dsq-author-user-2287">Doktoro Kiu</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2287" class="dsq-comment-body">
            <div id="dsq-comment-message-2287" class="dsq-comment-message"><p>I couldn&#8217;t tell you, and I&#8217;ve tried to use it a few times.  The real question is: how do you actually use the &#8220;help&#8221; program that inherits the finger-bending emacs interface.  I&#8217;ve been through the tutorial at least three times and I can never use that thing without a manual (lol).</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2319">
        <div id="dsq-comment-header-2319" class="dsq-comment-header">
            <cite id="dsq-cite-2319">
                <span id="dsq-author-user-2319">Thuglas Nasty</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2319" class="dsq-comment-body">
            <div id="dsq-comment-message-2319" class="dsq-comment-message"><p>I just reboot my computer</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2337">
        <div id="dsq-comment-header-2337" class="dsq-comment-header">
            <cite id="dsq-cite-2337">
                <a id="dsq-author-user-2337" href="http://taihendaro.cynic.net/" target="_blank" rel="nofollow">Curt J. Sampson</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2337" class="dsq-comment-body">
            <div id="dsq-comment-message-2337" class="dsq-comment-message"><p>There&#8217;s never any reason to exit emacs.</p>
<p>However, if you really feel feel the urge, I believe that the approved way is, Meta-! <code>shutdown -P now</code> .</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2524">
        <div id="dsq-comment-header-2524" class="dsq-comment-header">
            <cite id="dsq-cite-2524">
                <span id="dsq-author-user-2524">Adrian Lopez</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2524" class="dsq-comment-body">
            <div id="dsq-comment-message-2524" class="dsq-comment-message"><p>You have to call Richard Stallman. The issue is that he doesn&#8217;t use phone or email. You have to knock on his door.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-2280">
        <div id="dsq-comment-header-2280" class="dsq-comment-header">
            <cite id="dsq-cite-2280">
                <span id="dsq-author-user-2280">Emir I. Kurtovic</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2280" class="dsq-comment-body">
            <div id="dsq-comment-message-2280" class="dsq-comment-message"><p>or: how to get non-breakable password<br />
Give frontend developer task to exit VIM and capture output when he quits trying 🙂</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2298">
        <div id="dsq-comment-header-2298" class="dsq-comment-header">
            <cite id="dsq-cite-2298">
                <span id="dsq-author-user-2298">Patrick Jones</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2298" class="dsq-comment-body">
            <div id="dsq-comment-message-2298" class="dsq-comment-message"><p>:Quit:QUIT:QUIT!:q:q:q:q:q:q:qq:qw:qw:save:save &#8230; etc</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2302">
        <div id="dsq-comment-header-2302" class="dsq-comment-header">
            <cite id="dsq-cite-2302">
                <span id="dsq-author-user-2302">Seiti Yamashiro</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2302" class="dsq-comment-body">
            <div id="dsq-comment-message-2302" class="dsq-comment-message"><p>Hold the door! Hold the door! Holdthedoor! &#8230;.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-even depth-1" id="dsq-comment-2281">
        <div id="dsq-comment-header-2281" class="dsq-comment-header">
            <cite id="dsq-cite-2281">
                <span id="dsq-author-user-2281">Mert Mumtaz</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2281" class="dsq-comment-body">
            <div id="dsq-comment-message-2281" class="dsq-comment-message"><p>restart windows</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-2282">
        <div id="dsq-comment-header-2282" class="dsq-comment-header">
            <cite id="dsq-cite-2282">
                <span id="dsq-author-user-2282">Owen Iverson</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2282" class="dsq-comment-body">
            <div id="dsq-comment-message-2282" class="dsq-comment-message"><p>reimage&#8230;</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even thread-even depth-1" id="dsq-comment-2286">
        <div id="dsq-comment-header-2286" class="dsq-comment-header">
            <cite id="dsq-cite-2286">
                <span id="dsq-author-user-2286">Doktoro Kiu</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2286" class="dsq-comment-body">
            <div id="dsq-comment-message-2286" class="dsq-comment-message"><p>I would say the blame belongs with whatever GUI tool they are using to do git commits, not with vim.  Or, in my opinion, it lies with the misguided people who thought it made sense to avoid teaching a couple generations of developers/programmers/engineers how to use a posix-compliant shell and utilities.  My university sadly went to Visual Studio to teach engineers how to program in C, so those after me will never even be exposed to gcc.</p>
<p>I&#8217;m also confused how people who use a GUI tool don&#8217;t just close the terminal emulator, or if they are using a shell how they wouldn&#8217;t know how to at least suspend a process and bring up a man page.</p>
<p>I am half convinced that most of the &#8220;hits&#8221; are people linked to it as a joke about vim&#8217;s unique interface (I am one of the C-searching vimmers who have been linked to it as a joke).  If I recall correctly one of the comments goes something like &#8220;I&#8217;ve been using vim for 10 years.<br />
 I never could figure out how to quit.&#8221;</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2294">
        <div id="dsq-comment-header-2294" class="dsq-comment-header">
            <cite id="dsq-cite-2294">
                <span id="dsq-author-user-2294">Cameron Pickerill</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2294" class="dsq-comment-body">
            <div id="dsq-comment-message-2294" class="dsq-comment-message"><p>I doubt there&#8217;s much lost by ditching old editors. </p>
<p>My university made me learn to use vim, Unix shell, and gdb, but so far it&#8217;s been a worthless skillset.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-3" id="dsq-comment-2311">
        <div id="dsq-comment-header-2311" class="dsq-comment-header">
            <cite id="dsq-cite-2311">
                <a id="dsq-author-user-2311" href="http://www.liquidgate.it" target="_blank" rel="nofollow">DarioCorno</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2311" class="dsq-comment-body">
            <div id="dsq-comment-message-2311" class="dsq-comment-message"><p>In the cloud era, you&#8217;ll be thankful being able to use them on a remote server.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-4" id="dsq-comment-2383">
        <div id="dsq-comment-header-2383" class="dsq-comment-header">
            <cite id="dsq-cite-2383">
                <span id="dsq-author-user-2383">Max</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2383" class="dsq-comment-body">
            <div id="dsq-comment-message-2383" class="dsq-comment-message"><p>It&#8217;s annoying when you can&#8217;t just ssh in and do stuff.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even depth-3" id="dsq-comment-2321">
        <div id="dsq-comment-header-2321" class="dsq-comment-header">
            <cite id="dsq-cite-2321">
                <span id="dsq-author-user-2321">Roman Alexeev</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2321" class="dsq-comment-body">
            <div id="dsq-comment-message-2321" class="dsq-comment-message"><p>If bash &amp; vim &amp; Unix tools in general are a worthless skillset for you, that means you never ssh-ed to a misbehaving machine to figure out what&#8217;s wrong. Never hacked together a proof-of-concept service. Never tried to figure out why your script spits outs some errors about a database it can&#8217;t find. It means your experience was limited to pristine conditions, and any troubleshooting was limited to opening a JIRA ticket. I guess you can make a living doing Windows programming or something, but never even trying to spin up a spin up a webservice, or logging in to your router? Jeez.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-4" id="dsq-comment-2382">
        <div id="dsq-comment-header-2382" class="dsq-comment-header">
            <cite id="dsq-cite-2382">
                <span id="dsq-author-user-2382">Max</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2382" class="dsq-comment-body">
            <div id="dsq-comment-message-2382" class="dsq-comment-message"><p>Never done anything cool on a Raspberry Pi. He&#8217;s missing out on a lot!</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even depth-3" id="dsq-comment-2324">
        <div id="dsq-comment-header-2324" class="dsq-comment-header">
            <cite id="dsq-cite-2324">
                <span id="dsq-author-user-2324">Doktoro Kiu</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2324" class="dsq-comment-body">
            <div id="dsq-comment-message-2324" class="dsq-comment-message"><p>So you never use the shell or command-line programs (directly or indirectly) for anything you do?  I know some environments let you get by without them (visual studio), but many still require that knowledge to do many tasks (project setup stuff like paths, compiler options, etc).  I&#8217;m not sure how vim&#8217;s editing power would be useless, unless you were taught how to make it behave like notepad and nothing more.  Even if I developed on VS I would get immense value from the vim emulation plugin (combined with intellisense it is a dream).</p>
<p>On that note, the CLI editors are not &#8220;old&#8221;, since they are very much current in terms of features, and cutting edge with some plugins.  There&#8217;s a reason almost every editor and IDE has a vim compatibility plugin; it provides value.  The same is true for why Microsoft has made powershell and added the WSL in the recent update.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-3" id="dsq-comment-2379">
        <div id="dsq-comment-header-2379" class="dsq-comment-header">
            <cite id="dsq-cite-2379">
                <span id="dsq-author-user-2379">Max</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2379" class="dsq-comment-body">
            <div id="dsq-comment-message-2379" class="dsq-comment-message"><p>Mine too, way back in 1988. Vi and Emacs. Use them all day every day.</p>
<p>BTW Emacs = editor for middle aged computer scientist.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-4" id="dsq-comment-2427">
        <div id="dsq-comment-header-2427" class="dsq-comment-header">
            <cite id="dsq-cite-2427">
                <a id="dsq-author-user-2427" href="http://scorcher.org/" target="_blank" rel="nofollow">Jym Dyer</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2427" class="dsq-comment-body">
            <div id="dsq-comment-message-2427" class="dsq-comment-message"><p>Emacs is for middle-aged Lisp hackers, younger Clojure hackers, and everyone else with brains.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2310">
        <div id="dsq-comment-header-2310" class="dsq-comment-header">
            <cite id="dsq-cite-2310">
                <span id="dsq-author-user-2310">Erick</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2310" class="dsq-comment-body">
            <div id="dsq-comment-message-2310" class="dsq-comment-message"><p>I have been making a good living as a programmer for 10+ years writing C# and VB in Visual Studio. Programming in college was mostly Java and C/C++ using Eclipse. I&#8217;m lost in vim but that&#8217;s never once caused a problem professionally because I take jobs looking for C#/VB developers. How can you say it&#8217;s &#8220;misguided&#8221; to teach/learn a programming language and tools that can literally sustain one&#8217;s entire career?</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-3" id="dsq-comment-2363">
        <div id="dsq-comment-header-2363" class="dsq-comment-header">
            <cite id="dsq-cite-2363">
                <span id="dsq-author-user-2363">Doktoro Kiu</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2363" class="dsq-comment-body">
            <div id="dsq-comment-message-2363" class="dsq-comment-message"><p>I said it was misguided to avoid teaching CLI tools and the shell, not that it was misguided to teach standard GUI tools.  Note the difference.</p>
<p>Visual studio is perhaps the single largest area where knowledge of the CLI way is not helpful due to how tailored the system is to MS-specific workflows.  VS is a fantastic tool that supports MS tech as good as anyone could ask for, but I can&#8217;t use it to code for (truly) embedded systems, or for any arbitrary project that I can use a programming editor for.  Its integration is both its weakness and its strength.  Perhaps the VS Code editor might fill that niche, but it does not compare to vim quite yet.</p>
<p>Microsoft has provided useful Powershell cmdlets for most of their tools, and things like tfsvc have powerful cross-platform command-line clients that can do more intricate tasks than the IDE interface, so you lose out by avoiding the command-line.  And there is certainly a reason why they made Powershell and have committed to supporting it for all MS tools, and why they have recently added the WSL to get full GNU/Linux tools on Windows &#8220;natively&#8221;.  They&#8217;re even updating the ancient Windows command prompt, so clearly they have noticed that these areas are lacking enough to want to do something about it.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-4" id="dsq-comment-2369">
        <div id="dsq-comment-header-2369" class="dsq-comment-header">
            <cite id="dsq-cite-2369">
                <span id="dsq-author-user-2369">neminem</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2369" class="dsq-comment-body">
            <div id="dsq-comment-message-2369" class="dsq-comment-message"><p>Fun fact: it&#8217;s possible to know how and when to use plenty of command line tools, and *still* not ever use, or want to use, a clunky user-unfriendly tool like vim. I mean, use vim if you want, I won&#8217;t tell you not to, but &#8220;either you only use a single IDE interface and nothing else, or you use vim&#8221;, is pretty clearly a false dichotomy.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2293">
        <div id="dsq-comment-header-2293" class="dsq-comment-header">
            <cite id="dsq-cite-2293">
                <span id="dsq-author-user-2293">John Hascall</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2293" class="dsq-comment-body">
            <div id="dsq-comment-message-2293" class="dsq-comment-message"><p>Can&#8217;t figure out how to exit an editor?  Maybe it&#8217;s time to exit the profession&#8230; 😉</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2296">
        <div id="dsq-comment-header-2296" class="dsq-comment-header">
            <cite id="dsq-cite-2296">
                <span id="dsq-author-user-2296">Elijah</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2296" class="dsq-comment-body">
            <div id="dsq-comment-message-2296" class="dsq-comment-message"><p>maybe it&#8217;s time to move forward. you know.. technology and shit. advancement. better things&#8230;</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-3" id="dsq-comment-2301">
        <div id="dsq-comment-header-2301" class="dsq-comment-header">
            <cite id="dsq-cite-2301">
                <span id="dsq-author-user-2301">Ben</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2301" class="dsq-comment-body">
            <div id="dsq-comment-message-2301" class="dsq-comment-message"><p>nothing wrong with using vim. It is installed by default on most linux distros meaning that you can edit code easily on any machine without having to worry about what editor/IDE is available. It is also extremely fast when you use it regularly. There is always going to be a use case for vim.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-3" id="dsq-comment-2305">
        <div id="dsq-comment-header-2305" class="dsq-comment-header">
            <cite id="dsq-cite-2305">
                <span id="dsq-author-user-2305">Pierce Corcoran</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2305" class="dsq-comment-body">
            <div id="dsq-comment-message-2305" class="dsq-comment-message"><p>I would pretend to get angry, but that would just perpetuate a stereotype.</p>
<p>Vim4lyfe</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-3" id="dsq-comment-2306">
        <div id="dsq-comment-header-2306" class="dsq-comment-header">
            <cite id="dsq-cite-2306">
                <span id="dsq-author-user-2306">Luciano Unknown</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2306" class="dsq-comment-body">
            <div id="dsq-comment-message-2306" class="dsq-comment-message"><p>Go back to your visual studio</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-3" id="dsq-comment-2312">
        <div id="dsq-comment-header-2312" class="dsq-comment-header">
            <cite id="dsq-cite-2312">
                <span id="dsq-author-user-2312">pepe Sandoval</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2312" class="dsq-comment-body">
            <div id="dsq-comment-message-2312" class="dsq-comment-message"><p>If there were something better, I would gladly use it.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-3" id="dsq-comment-2365">
        <div id="dsq-comment-header-2365" class="dsq-comment-header">
            <cite id="dsq-cite-2365">
                <span id="dsq-author-user-2365">Doktoro Kiu</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2365" class="dsq-comment-body">
            <div id="dsq-comment-message-2365" class="dsq-comment-message"><p>That might be valid if vim or other CLI tools were not updated continuously with new features.  With plugins you can get some bleeding-edge features lacking in common IDEs.  With all of their recent support for CLI (Powershell, WSL, updates to the old cmd.exe console) it appears we must be moving forwards after all.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2299">
        <div id="dsq-comment-header-2299" class="dsq-comment-header">
            <cite id="dsq-cite-2299">
                <span id="dsq-author-user-2299">Sarah Parker</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2299" class="dsq-comment-body">
            <div id="dsq-comment-message-2299" class="dsq-comment-message"><p>These are probably people who have never used it before, no need to be so obnoxious. </p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2309">
        <div id="dsq-comment-header-2309" class="dsq-comment-header">
            <cite id="dsq-cite-2309">
                <a id="dsq-author-user-2309" href="http://www.liquidgate.it" target="_blank" rel="nofollow">DarioCorno</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2309" class="dsq-comment-body">
            <div id="dsq-comment-message-2309" class="dsq-comment-message"><p>Bet you where born with that particular piece of knowledge on how to exit the vim editor, hu?</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2317">
        <div id="dsq-comment-header-2317" class="dsq-comment-header">
            <cite id="dsq-cite-2317">
                <span id="dsq-author-user-2317">iDerailThings</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2317" class="dsq-comment-body">
            <div id="dsq-comment-message-2317" class="dsq-comment-message"><p>I logged into Disqus just to downvote you. An editor is an ephemeral tool to be replaced by the next whiz bang text processor. knowing or not knowing has no impact on your performance as a developer. Get gud.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-3" id="dsq-comment-2357">
        <div id="dsq-comment-header-2357" class="dsq-comment-header">
            <cite id="dsq-cite-2357">
                <span id="dsq-author-user-2357">Cronky</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2357" class="dsq-comment-body">
            <div id="dsq-comment-message-2357" class="dsq-comment-message"><p>I logged into Disqus just to down vote you for using the word ephemeral.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-4" id="dsq-comment-2364">
        <div id="dsq-comment-header-2364" class="dsq-comment-header">
            <cite id="dsq-cite-2364">
                <span id="dsq-author-user-2364">iDerailThings</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2364" class="dsq-comment-body">
            <div id="dsq-comment-message-2364" class="dsq-comment-message"><p>scrub</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-5" id="dsq-comment-2370">
        <div id="dsq-comment-header-2370" class="dsq-comment-header">
            <cite id="dsq-cite-2370">
                <span id="dsq-author-user-2370">Cronky</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2370" class="dsq-comment-body">
            <div id="dsq-comment-message-2370" class="dsq-comment-message"><p>Trump</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-5" id="dsq-comment-2377">
        <div id="dsq-comment-header-2377" class="dsq-comment-header">
            <cite id="dsq-cite-2377">
                <span id="dsq-author-user-2377">Max</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2377" class="dsq-comment-body">
            <div id="dsq-comment-message-2377" class="dsq-comment-message"><p>Literally Hitler.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2318">
        <div id="dsq-comment-header-2318" class="dsq-comment-header">
            <cite id="dsq-cite-2318">
                <span id="dsq-author-user-2318">Thuglas Nasty</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2318" class="dsq-comment-body">
            <div id="dsq-comment-message-2318" class="dsq-comment-message"><p>So euphoric, you must be, wizard.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2295">
        <div id="dsq-comment-header-2295" class="dsq-comment-header">
            <cite id="dsq-cite-2295">
                <a id="dsq-author-user-2295" href="http://lavinski.me/" target="_blank" rel="nofollow">Daniel Little</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2295" class="dsq-comment-body">
            <div id="dsq-comment-message-2295" class="dsq-comment-message"><p>git commit</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2300">
        <div id="dsq-comment-header-2300" class="dsq-comment-header">
            <cite id="dsq-cite-2300">
                <span id="dsq-author-user-2300">zutroy101</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2300" class="dsq-comment-body">
            <div id="dsq-comment-message-2300" class="dsq-comment-message"><p>Is that 1 million unique views?</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2307">
        <div id="dsq-comment-header-2307" class="dsq-comment-header">
            <cite id="dsq-cite-2307">
                <span id="dsq-author-user-2307">OK_Komputer</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2307" class="dsq-comment-body">
            <div id="dsq-comment-message-2307" class="dsq-comment-message"><p>No, we are dealing with a massive spread of multiple sclerosis</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-even depth-1" id="dsq-comment-2303">
        <div id="dsq-comment-header-2303" class="dsq-comment-header">
            <cite id="dsq-cite-2303">
                <a id="dsq-author-user-2303" href="http://oncebuilder.com" target="_blank" rel="nofollow">OnceBuilder CMS</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2303" class="dsq-comment-body">
            <div id="dsq-comment-message-2303" class="dsq-comment-message"><p>Awesome&#8230;so inspiring</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-2308">
        <div id="dsq-comment-header-2308" class="dsq-comment-header">
            <cite id="dsq-cite-2308">
                <span id="dsq-author-user-2308">Göran Törnquist</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2308" class="dsq-comment-body">
            <div id="dsq-comment-message-2308" class="dsq-comment-message"><p>I would like to know how many of those were originating from making a simple `git commit` and forgetting to specify -m</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even thread-even depth-1" id="dsq-comment-2314">
        <div id="dsq-comment-header-2314" class="dsq-comment-header">
            <cite id="dsq-cite-2314">
                <span id="dsq-author-user-2314">Daniel</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2314" class="dsq-comment-body">
            <div id="dsq-comment-message-2314" class="dsq-comment-message"><p>&gt; In contrast, in China, Korea and Japan the fraction going to this question is one-tenth as much. That might indicate that when developers in these countries enter Vim, they usually meant to do so, and they know how to get out of it.</p>
<p>I think that this just indicates that they don&#8217;t use English when searching on Internet.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2315">
        <div id="dsq-comment-header-2315" class="dsq-comment-header">
            <cite id="dsq-cite-2315">
                <a id="dsq-author-user-2315" href="http://ralphembree.blg.lt" target="_blank" rel="nofollow">Ralph Embree</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2315" class="dsq-comment-body">
            <div id="dsq-comment-message-2315" class="dsq-comment-message"><p>All of the other Vim questions would also be in English, so how would that change anything? (Note that it&#8217;s percentage that is being charted here, not just number).</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-3" id="dsq-comment-2325">
        <div id="dsq-comment-header-2325" class="dsq-comment-header">
            <cite id="dsq-cite-2325">
                <span id="dsq-author-user-2325">jaymzru</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2325" class="dsq-comment-body">
            <div id="dsq-comment-message-2325" class="dsq-comment-message"><p>For Japanese developers in particular, they&#8217;re probably looking it up on qiita.com/ which is the (more popular) Japanese knock-off of stackoverflow.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-4" id="dsq-comment-2328">
        <div id="dsq-comment-header-2328" class="dsq-comment-header">
            <cite id="dsq-cite-2328">
                <a id="dsq-author-user-2328" href="http://ralphembree.blg.lt" target="_blank" rel="nofollow">Ralph Embree</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2328" class="dsq-comment-body">
            <div id="dsq-comment-message-2328" class="dsq-comment-message"><p>My point is that it is percentages that are being tracked here. Do you think it&#8217;s likely that they look up how to exit Vim in their native language, but ask all their other Vim questions on Stack Overflow?</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2333">
        <div id="dsq-comment-header-2333" class="dsq-comment-header">
            <cite id="dsq-cite-2333">
                <a id="dsq-author-user-2333" href="http://kerim.oxus.net/" target="_blank" rel="nofollow">Kerim</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2333" class="dsq-comment-body">
            <div id="dsq-comment-message-2333" class="dsq-comment-message"><p>Exactly. This post on Baidu has been saved over two million times&#8230; &#8221;</p>
<p><a href="http://tieba.baidu.com/p/345164921" rel="nofollow">http://tieba.baidu.com/p/345164921</a></p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2374">
        <div id="dsq-comment-header-2374" class="dsq-comment-header">
            <cite id="dsq-cite-2374">
                <span id="dsq-author-user-2374">Reorx</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2374" class="dsq-comment-body">
            <div id="dsq-comment-message-2374" class="dsq-comment-message"><p>The page doesn&#8217;t show how many times it is viewed, if what you mean by 2 million is this part “贴子：2,233,227”, it is actually the total number of topics in Linux group (group in Baidu tieba is like subreddit in reddit)</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-4" id="dsq-comment-2404">
        <div id="dsq-comment-header-2404" class="dsq-comment-header">
            <cite id="dsq-cite-2404">
                <a id="dsq-author-user-2404" href="http://kerim.oxus.net/" target="_blank" rel="nofollow">Kerim</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2404" class="dsq-comment-body">
            <div id="dsq-comment-message-2404" class="dsq-comment-message"><p>OK, but that&#8217;s still 2 mil looking for Linux info in a Chinese language forum, implying that we can&#8217;t assume the fact that less people access stackoverflow from China implies they don&#8217;t need help.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-5" id="dsq-comment-2405">
        <div id="dsq-comment-header-2405" class="dsq-comment-header">
            <cite id="dsq-cite-2405">
                <span id="dsq-author-user-2405">Reorx</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2405" class="dsq-comment-body">
            <div id="dsq-comment-message-2405" class="dsq-comment-message"><p>That&#8217;s right, I agree with your point 🙂</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2316">
        <div id="dsq-comment-header-2316" class="dsq-comment-header">
            <cite id="dsq-cite-2316">
                <span id="dsq-author-user-2316">Eko Suprapto Wibowo</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2316" class="dsq-comment-body">
            <div id="dsq-comment-message-2316" class="dsq-comment-message"><p>Ahaha. Totally amusing!<br />
I was once ViM love, but now I am more to Emacs.<br />
C-x C-c</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2326">
        <div id="dsq-comment-header-2326" class="dsq-comment-header">
            <cite id="dsq-cite-2326">
                <span id="dsq-author-user-2326">Coding.JS</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2326" class="dsq-comment-body">
            <div id="dsq-comment-message-2326" class="dsq-comment-message"><p>One does not simply use a Lord Of The Rings meme to advertise Vim&#8230;</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2327">
        <div id="dsq-comment-header-2327" class="dsq-comment-header">
            <cite id="dsq-cite-2327">
                <a id="dsq-author-user-2327" href="https://DonaldFoss.com/" target="_blank" rel="nofollow">Donald E. Foss</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2327" class="dsq-comment-body">
            <div id="dsq-comment-message-2327" class="dsq-comment-message"><p>Two thoughts: </p>
<p>1) This shows the rapid rise in the entry of uni grads who only learned to code on virtual machines. In the years on the left side of your time series graph, there were more hard code types in the profession.</p>
<p>2) How can I use the alternative editor which switches to a help screen when I hit backspace? </p>
<p>I agree with your original assertion; the poor person didn&#8217;t meant or want to be in vi, but there they are. It&#8217;s time to go get the O&#8217;Reilly vi pocket-sized book and sleep with it under their pillows a few nights.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2329">
        <div id="dsq-comment-header-2329" class="dsq-comment-header">
            <cite id="dsq-cite-2329">
                <span id="dsq-author-user-2329">David Nguyen</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2329" class="dsq-comment-body">
            <div id="dsq-comment-message-2329" class="dsq-comment-message"><p>Oh, so funny</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2331">
        <div id="dsq-comment-header-2331" class="dsq-comment-header">
            <cite id="dsq-cite-2331">
                <span id="dsq-author-user-2331">Richard C Yeh</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2331" class="dsq-comment-body">
            <div id="dsq-comment-message-2331" class="dsq-comment-message"><p>How do people know they&#8217;re in the Vim editor and not, say, ed? (I mean, I know how I know, but how do people know to type &#8220;vim&#8221; into Google?)</p>
<p>To the author: is the “Exit Vim / Total Vim” ratio conditional on visiting the Exit Vim page?</p>
<p>Thanks to Spolsky for tweeting this article!  </p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2332">
        <div id="dsq-comment-header-2332" class="dsq-comment-header">
            <cite id="dsq-cite-2332">
                <span id="dsq-author-user-2332">andrewjgrimm</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2332" class="dsq-comment-body">
            <div id="dsq-comment-message-2332" class="dsq-comment-message"><p>Can you show statistics of Ruby programmers from Japan, if possible excluding expats (those whose web browsers prefer English perhaps?)?</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2336">
        <div id="dsq-comment-header-2336" class="dsq-comment-header">
            <cite id="dsq-cite-2336">
                <span id="dsq-author-user-2336">Michael Elliott</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2336" class="dsq-comment-body">
            <div id="dsq-comment-message-2336" class="dsq-comment-message"><p>Really? Why?</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2355">
        <div id="dsq-comment-header-2355" class="dsq-comment-header">
            <cite id="dsq-cite-2355">
                <span id="dsq-author-user-2355">andrewjgrimm</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2355" class="dsq-comment-body">
            <div id="dsq-comment-message-2355" class="dsq-comment-message"><p>Because if Japanese people are good at vim, and if programmers of Ruby (which was created in Japan) are good at vim, then I hypothesise that combining those two categories would show a group that&#8217;s really good at vim.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-4" id="dsq-comment-2378">
        <div id="dsq-comment-header-2378" class="dsq-comment-header">
            <cite id="dsq-cite-2378">
                <span id="dsq-author-user-2378">RebeccaH</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2378" class="dsq-comment-body">
            <div id="dsq-comment-message-2378" class="dsq-comment-message"><p>I&#8217;m working in Japan for years.<br />
As for as I can tell, most of my Japanese fellows use sublime rather than vim.<br />
Only a few of them mastered vim.<br />
Some of them even don&#8217;t use vim plugins.<br />
As my fellows prefer to google in Japanese, there&#8217;ll be less possibility for them to resort to stackoverflow.<br />
Besides, there is a Japanese website somewhat like stackoverflow called Qiita.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-2335">
        <div id="dsq-comment-header-2335" class="dsq-comment-header">
            <cite id="dsq-cite-2335">
                <span id="dsq-author-user-2335">David Hughes</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2335" class="dsq-comment-body">
            <div id="dsq-comment-message-2335" class="dsq-comment-message"><p>Damn it Canada we can do better!</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even thread-even depth-1" id="dsq-comment-2338">
        <div id="dsq-comment-header-2338" class="dsq-comment-header">
            <cite id="dsq-cite-2338">
                <span id="dsq-author-user-2338">Papayaman1000</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2338" class="dsq-comment-body">
            <div id="dsq-comment-message-2338" class="dsq-comment-message"><p>I feel like it would&#8217;ve been a nice touch to include how to exit vim from this page. I managed to open it with vim somehow and can&#8217;t use the links, and so I&#8217;m still stuck in vim. Send help.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2339">
        <div id="dsq-comment-header-2339" class="dsq-comment-header">
            <cite id="dsq-cite-2339">
                <a id="dsq-author-user-2339" href="http://ralphembree.blg.lt" target="_blank" rel="nofollow">Ralph Embree</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2339" class="dsq-comment-body">
            <div id="dsq-comment-message-2339" class="dsq-comment-message"><p>Can&#8217;t use the links? Oh, well. Go into &#8220;normal&#8221; mode (which is not normal for newbie Vim users) by hitting Escape. Next, type the cutesie emoticon :q! (I assume you don&#8217;t want to save changes.)</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-3" id="dsq-comment-2349">
        <div id="dsq-comment-header-2349" class="dsq-comment-header">
            <cite id="dsq-cite-2349">
                <a id="dsq-author-user-2349" href="http://facebook.com/FalconFour" target="_blank" rel="nofollow">Matt Falcon</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2349" class="dsq-comment-body">
            <div id="dsq-comment-message-2349" class="dsq-comment-message"><p>&#8220;The cutesie emoticon :q! &#8220;.</p>
<p>Fantastic. Now I&#8217;ll never again forget how to quit vim! Damn&#8230; just a memory trick would do it&#8230; if that were in the original answer, we&#8217;d probably have another few years to go in reaching 1m views. 😉</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-3" id="dsq-comment-2368">
        <div id="dsq-comment-header-2368" class="dsq-comment-header">
            <cite id="dsq-cite-2368">
                <span id="dsq-author-user-2368">neminem</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2368" class="dsq-comment-body">
            <div id="dsq-comment-message-2368" class="dsq-comment-message"><p>Looks like someone sticking out his tongue, and then getting smacked with a baseball bat as a result. (Which is a great depiction of the sort of person who uses vim regularly, so that works pretty well.)</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2340">
        <div id="dsq-comment-header-2340" class="dsq-comment-header">
            <cite id="dsq-cite-2340">
                <span id="dsq-author-user-2340">peterh</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2340" class="dsq-comment-body">
            <div id="dsq-comment-message-2340" class="dsq-comment-message"><p>It seems there are still not enough vim developers in Japan and China. Maybe the vim development should come out with an improved support of Far East languages.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2342">
        <div id="dsq-comment-header-2342" class="dsq-comment-header">
            <cite id="dsq-cite-2342">
                <span id="dsq-author-user-2342">ronbreen</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2342" class="dsq-comment-body">
            <div id="dsq-comment-message-2342" class="dsq-comment-message"><p>I see a whole audience of pimple-faced, self-serving, one-ups-manship Linux geeks out there who are so protective of their fiefdoms that all they can do is ridicule the uninformed in the hopes of scaring them away &#8230; thus preserving the mystery of the holy grail of software engin-erring.  Yes, developing software is more about</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2348">
        <div id="dsq-comment-header-2348" class="dsq-comment-header">
            <cite id="dsq-cite-2348">
                <a id="dsq-author-user-2348" href="http://facebook.com/FalconFour" target="_blank" rel="nofollow">Matt Falcon</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2348" class="dsq-comment-body">
            <div id="dsq-comment-message-2348" class="dsq-comment-message"><p>Despite your lack of ability to form thoughts into a single coherent comment instead of 3&#8230; I agree. The fact that vim is still the preferred editor of choice is maddening. (give me Nano any day)</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2359">
        <div id="dsq-comment-header-2359" class="dsq-comment-header">
            <cite id="dsq-cite-2359">
                <span id="dsq-author-user-2359">Pohojan poika</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2359" class="dsq-comment-body">
            <div id="dsq-comment-message-2359" class="dsq-comment-message"><p>That is what happened to Nokia and Symbian. The development of Symbian software was a real pain in the ass, but they thought this was good because this meant that only &#8220;real programmers&#8221; were able to develop software for Symbian devices.</p>
<p>If it was easy anyone could do it, they would have not felt so special.</p>
<p>Unsurprisingly, the moment they got some viable alternative almost everyone was ready to jump ship.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-3" id="dsq-comment-2376">
        <div id="dsq-comment-header-2376" class="dsq-comment-header">
            <cite id="dsq-cite-2376">
                <span id="dsq-author-user-2376">shompol</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2376" class="dsq-comment-body">
            <div id="dsq-comment-message-2376" class="dsq-comment-message"><p>Microsoft killed Nokia by installing their proxy as Nokia CEO. Nokia was developing a MeGo operating system to replace Symbian before the new CEO killed it and proceeded to bankrupt the company.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-4" id="dsq-comment-2386">
        <div id="dsq-comment-header-2386" class="dsq-comment-header">
            <cite id="dsq-cite-2386">
                <span id="dsq-author-user-2386">Pohojan poika</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2386" class="dsq-comment-body">
            <div id="dsq-comment-message-2386" class="dsq-comment-message"><p>I was working at Nokia in software development at the time.</p>
<p>The culture especially towards Symbian was totally weird.</p>
<p>The language was utter crap, with peculiarities that were there just to circumvent bugs in an IDE from the year 1996, but they worshipped it like it was good *because* it was crap.</p>
<p>I was told countless different times, by many different people things like:</p>
<p>&#8220;People who are not good enough developers to enjoy Symbian, should not work here.&#8221;</p>
<p>&#8220;We don&#8217;t need to make this easier, because this way only people who really know how to write code work here.&#8221; </p>
<p>They even asked a developer I know to remove features from the library he had written that made sure all the necessary memory gets released, because &#8220;If somebody doesn&#8217;t remember to release all the memory, he is not good enough developer to work here.&#8221;</p>
<p>This all ran counter to common sense. The more developers, the more software, the more users and the more viable ecosystem.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2343">
        <div id="dsq-comment-header-2343" class="dsq-comment-header">
            <cite id="dsq-cite-2343">
                <span id="dsq-author-user-2343">ronbreen</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2343" class="dsq-comment-body">
            <div id="dsq-comment-message-2343" class="dsq-comment-message"><p>erring and less about everything else.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2344">
        <div id="dsq-comment-header-2344" class="dsq-comment-header">
            <cite id="dsq-cite-2344">
                <span id="dsq-author-user-2344">ronbreen</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2344" class="dsq-comment-body">
            <div id="dsq-comment-message-2344" class="dsq-comment-message"><p>Try: man vim</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2347">
        <div id="dsq-comment-header-2347" class="dsq-comment-header">
            <cite id="dsq-cite-2347">
                <a id="dsq-author-user-2347" href="http://facebook.com/FalconFour" target="_blank" rel="nofollow">Matt Falcon</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2347" class="dsq-comment-body">
            <div id="dsq-comment-message-2347" class="dsq-comment-message"><p>Great plan. Propose a way to figure out how to do that while you&#8217;re already in vim? Note the &#8220;figuring out&#8221; part&#8230; how would you get to a place you could &#8220;man&#8221; it if you&#8217;re already IN VIM and can&#8217;t escape?</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2350">
        <div id="dsq-comment-header-2350" class="dsq-comment-header">
            <cite id="dsq-cite-2350">
                <span id="dsq-author-user-2350">duder1</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2350" class="dsq-comment-body">
            <div id="dsq-comment-message-2350" class="dsq-comment-message"><p>hit the k button lol</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-3" id="dsq-comment-2351">
        <div id="dsq-comment-header-2351" class="dsq-comment-header">
            <cite id="dsq-cite-2351">
                <span id="dsq-author-user-2351">Cronky</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2351" class="dsq-comment-body">
            <div id="dsq-comment-message-2351" class="dsq-comment-message"><p>:!man vim</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-3" id="dsq-comment-2352">
        <div id="dsq-comment-header-2352" class="dsq-comment-header">
            <cite id="dsq-cite-2352">
                <span id="dsq-author-user-2352">Garry Filakhtov</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2352" class="dsq-comment-body">
            <div id="dsq-comment-message-2352" class="dsq-comment-message"><p>!man vim<br />
Should do</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-3" id="dsq-comment-2358">
        <div id="dsq-comment-header-2358" class="dsq-comment-header">
            <cite id="dsq-cite-2358">
                <span id="dsq-author-user-2358">Colin</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2358" class="dsq-comment-body">
            <div id="dsq-comment-message-2358" class="dsq-comment-message"><p>Open another terminal?</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-3" id="dsq-comment-2402">
        <div id="dsq-comment-header-2402" class="dsq-comment-header">
            <cite id="dsq-cite-2402">
                <span id="dsq-author-user-2402">poiuz</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2402" class="dsq-comment-body">
            <div id="dsq-comment-message-2402" class="dsq-comment-message"><p>Come on. How can you google something if you are stuck in VIM? </p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-4" id="dsq-comment-2410">
        <div id="dsq-comment-header-2410" class="dsq-comment-header">
            <cite id="dsq-cite-2410">
                <span id="dsq-author-user-2410">Garry Filakhtov</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2410" class="dsq-comment-body">
            <div id="dsq-comment-message-2410" class="dsq-comment-message"><p>Smartphone? Your peers/partners laptop? Endless possibilities&#8230;</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-4" id="dsq-comment-2418">
        <div id="dsq-comment-header-2418" class="dsq-comment-header">
            <cite id="dsq-cite-2418">
                <span id="dsq-author-user-2418">CJSchneider2</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2418" class="dsq-comment-body">
            <div id="dsq-comment-message-2418" class="dsq-comment-message"><p> :! firefox <a href="http://lmgtfy.com/?q=how+to+exit+fim" rel="nofollow">http://lmgtfy.com/?q=how+to+exit+fim</a> &amp; </p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2373">
        <div id="dsq-comment-header-2373" class="dsq-comment-header">
            <cite id="dsq-cite-2373">
                <span id="dsq-author-user-2373">kyklous</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2373" class="dsq-comment-body">
            <div id="dsq-comment-message-2373" class="dsq-comment-message"><p>&#8220;I wrote man vim, but it shows inside the editor and nothing happens.&#8221;</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2399">
        <div id="dsq-comment-header-2399" class="dsq-comment-header">
            <cite id="dsq-cite-2399">
                <span id="dsq-author-user-2399">Chris Wesseling</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2399" class="dsq-comment-body">
            <div id="dsq-comment-message-2399" class="dsq-comment-message"><p>That is a blatant lie! You&#8217;re in command-mode,  so it will try to mark, and eventually, the v will put you in visual select mode&#8230;</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2353">
        <div id="dsq-comment-header-2353" class="dsq-comment-header">
            <cite id="dsq-cite-2353">
                <span id="dsq-author-user-2353">Valentin Ignatyev</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2353" class="dsq-comment-body">
            <div id="dsq-comment-message-2353" class="dsq-comment-message"><p>I just reboot my computer. Works every time.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2356">
        <div id="dsq-comment-header-2356" class="dsq-comment-header">
            <cite id="dsq-cite-2356">
                <span id="dsq-author-user-2356">Krittayot Techasombooranakit</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2356" class="dsq-comment-body">
            <div id="dsq-comment-message-2356" class="dsq-comment-message"><p>LOL, That&#8217;s clever.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2361">
        <div id="dsq-comment-header-2361" class="dsq-comment-header">
            <cite id="dsq-cite-2361">
                <span id="dsq-author-user-2361">Nick Roosevelt</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2361" class="dsq-comment-body">
            <div id="dsq-comment-message-2361" class="dsq-comment-message"><p>This is only the first step. Then you need to switch to emacs.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2390">
        <div id="dsq-comment-header-2390" class="dsq-comment-header">
            <cite id="dsq-cite-2390">
                <span id="dsq-author-user-2390">cedric simon</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2390" class="dsq-comment-body">
            <div id="dsq-comment-message-2390" class="dsq-comment-message"><p>exiting emacs is even harder lol.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-4" id="dsq-comment-2414">
        <div id="dsq-comment-header-2414" class="dsq-comment-header">
            <cite id="dsq-cite-2414">
                <a id="dsq-author-user-2414" href="https://schnell.news" target="_blank" rel="nofollow">Konstantin</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2414" class="dsq-comment-body">
            <div id="dsq-comment-message-2414" class="dsq-comment-message"><p>+ the combo you enter every time to end a process&#8230;</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-5" id="dsq-comment-2434">
        <div id="dsq-comment-header-2434" class="dsq-comment-header">
            <cite id="dsq-cite-2434">
                <span id="dsq-author-user-2434">Beobachter</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2434" class="dsq-comment-body">
            <div id="dsq-comment-message-2434" class="dsq-comment-message"><p>Not when inside Emacs.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2372">
        <div id="dsq-comment-header-2372" class="dsq-comment-header">
            <cite id="dsq-cite-2372">
                <span id="dsq-author-user-2372">kyklous</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2372" class="dsq-comment-body">
            <div id="dsq-comment-message-2372" class="dsq-comment-message"><p>hahahaahahaahhaahahahaahahaahahaahahahah</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2408">
        <div id="dsq-comment-header-2408" class="dsq-comment-header">
            <cite id="dsq-cite-2408">
                <span id="dsq-author-user-2408">Logan Zhou</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2408" class="dsq-comment-body">
            <div id="dsq-comment-message-2408" class="dsq-comment-message"><p>Thank you so much! It works. I have been stucked for a whole day.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2424">
        <div id="dsq-comment-header-2424" class="dsq-comment-header">
            <cite id="dsq-cite-2424">
                <a id="dsq-author-user-2424" href="http://t800.biz" target="_blank" rel="nofollow">vickodin</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2424" class="dsq-comment-body">
            <div id="dsq-comment-message-2424" class="dsq-comment-message"><p>That was funny :))</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2354">
        <div id="dsq-comment-header-2354" class="dsq-comment-header">
            <cite id="dsq-cite-2354">
                <span id="dsq-author-user-2354">Ronak Sunil Shah</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2354" class="dsq-comment-body">
            <div id="dsq-comment-message-2354" class="dsq-comment-message"><p>How can we conclude &#8220;In contrast, in China, Korea and Japan the fraction going to this question is one-tenth as much.&#8221; ?<br />
Probably they don&#8217;t use vim as high as other countries, hence the low traffic. Or did I miss something?</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2371">
        <div id="dsq-comment-header-2371" class="dsq-comment-header">
            <cite id="dsq-cite-2371">
                <span id="dsq-author-user-2371">nekoyumi</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2371" class="dsq-comment-body">
            <div id="dsq-comment-message-2371" class="dsq-comment-message"><p>It&#8217;s as a % of all Vim-related visits, so it would take that into account.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2375">
        <div id="dsq-comment-header-2375" class="dsq-comment-header">
            <cite id="dsq-cite-2375">
                <span id="dsq-author-user-2375">Reorx</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2375" class="dsq-comment-body">
            <div id="dsq-comment-message-2375" class="dsq-comment-message"><p>It&#8217;s the speaking language that makes difference, plus, people in China can not visit StackOverflow easily without a proxy.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-3" id="dsq-comment-2381">
        <div id="dsq-comment-header-2381" class="dsq-comment-header">
            <cite id="dsq-cite-2381">
                <span id="dsq-author-user-2381">Michael</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2381" class="dsq-comment-body">
            <div id="dsq-comment-message-2381" class="dsq-comment-message"><p>They can without a proxy.</p>
<p>Source: I&#8217;m a guy sitting in China right now without a Proxy/VPN.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-4" id="dsq-comment-2395">
        <div id="dsq-comment-header-2395" class="dsq-comment-header">
            <cite id="dsq-cite-2395">
                <a id="dsq-author-user-2395" href="http://eltonjain.com" target="_blank" rel="nofollow">Elton Jain</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2395" class="dsq-comment-body">
            <div id="dsq-comment-message-2395" class="dsq-comment-message"><p>Thanks for confirming.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-4" id="dsq-comment-2407">
        <div id="dsq-comment-header-2407" class="dsq-comment-header">
            <cite id="dsq-cite-2407">
                <span id="dsq-author-user-2407">Reorx</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2407" class="dsq-comment-body">
            <div id="dsq-comment-message-2407" class="dsq-comment-message"><p>Well, I didn&#8217;t say it&#8217;s totally impossible, in some area it has very high latency and drop rate when accessing a site in US, this makes StackOverflow very difficult to use. When you rely heavily on StackOverflow or Google, you have to use a proxy to make yourself happy.</p>
<p>Disclaimer: I&#8217;m a guy sitting in China using a Proxy</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2432">
        <div id="dsq-comment-header-2432" class="dsq-comment-header">
            <cite id="dsq-cite-2432">
                <span id="dsq-author-user-2432">PhasmaFelis</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2432" class="dsq-comment-body">
            <div id="dsq-comment-message-2432" class="dsq-comment-message"><p>Out of all the people from each country visiting questions tagged with Vim, this is what percentage visited this questions specifically.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2458">
        <div id="dsq-comment-header-2458" class="dsq-comment-header">
            <cite id="dsq-cite-2458">
                <span id="dsq-author-user-2458">Daniel</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2458" class="dsq-comment-body">
            <div id="dsq-comment-message-2458" class="dsq-comment-message"><p>They just quite often don&#8217;t Google in English, and they use other websites such as <a href="http://qiita.com/" rel="nofollow">http://qiita.com/</a> in Japan.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-2360">
        <div id="dsq-comment-header-2360" class="dsq-comment-header">
            <cite id="dsq-cite-2360">
                <a id="dsq-author-user-2360" href="http://kutemukan.com" target="_blank" rel="nofollow">Ruby</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2360" class="dsq-comment-body">
            <div id="dsq-comment-message-2360" class="dsq-comment-message"><p>LEL</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even thread-even depth-1" id="dsq-comment-2362">
        <div id="dsq-comment-header-2362" class="dsq-comment-header">
            <cite id="dsq-cite-2362">
                <span id="dsq-author-user-2362">thapakazi</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2362" class="dsq-comment-body">
            <div id="dsq-comment-message-2362" class="dsq-comment-message"><p>Now I get it tombh, why you made this novim-mode 😀<br />
 <a href="https://github.com/tombh/novim-mode" rel="nofollow">https://github.com/tombh/novim-mode</a></p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-2380">
        <div id="dsq-comment-header-2380" class="dsq-comment-header">
            <cite id="dsq-cite-2380">
                <a id="dsq-author-user-2380" href="https://schnell.news" target="_blank" rel="nofollow">Konstantin</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2380" class="dsq-comment-body">
            <div id="dsq-comment-message-2380" class="dsq-comment-message"><p>I literally access this question every single time I forgot &#8220;export VISUAL = nano&#8221; before crontab or so&#8230; Every time I somehow get into vi or vim I have to read it in order to be able to exit it.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2388">
        <div id="dsq-comment-header-2388" class="dsq-comment-header">
            <cite id="dsq-cite-2388">
                <span id="dsq-author-user-2388">cedric simon</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2388" class="dsq-comment-body">
            <div id="dsq-comment-message-2388" class="dsq-comment-message"><p>Like with any program on *nix, C-c can stop a program.</p>
<p>In VIm, there is a message in the status line at the bottom saying: &#8220;Type :quit to exit&#8221;</p>
<p>How is that difficult?</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2396">
        <div id="dsq-comment-header-2396" class="dsq-comment-header">
            <cite id="dsq-cite-2396">
                <span id="dsq-author-user-2396">Christopher Beck</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2396" class="dsq-comment-body">
            <div id="dsq-comment-message-2396" class="dsq-comment-message"><p>Have you seen the quality of developers today?</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-4" id="dsq-comment-2440">
        <div id="dsq-comment-header-2440" class="dsq-comment-header">
            <cite id="dsq-cite-2440">
                <span id="dsq-author-user-2440">Paweł Breś</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2440" class="dsq-comment-body">
            <div id="dsq-comment-message-2440" class="dsq-comment-message"><p>I have. I&#8217;ve had been making presentations about tesing frameworks and deployment tools to a few experianced developers and got stunned a couple of times. Though my favourite is:<br />
A developer wanted to quit a console script and he hit Ctrl + Z, Ctrl + X, Ctrl + C &#8211; in this exact order.<br />
&#8211; Me:  &#8220;What did you do?!&#8221;<br />
&#8211; D: &#8220;Exited script.&#8221; &#8211; responded with professional face as he would teach a kid<br />
&#8211; Me: &#8220;But why did you do all of those combinations?&#8221;<br />
&#8211; D: &#8220;I never remember which one is it so I hit them all&#8221;<br />
I just couldn&#8217;t find my words to explain him that he moved script to background and killed prompt for few minutes.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt depth-3" id="dsq-comment-2397">
        <div id="dsq-comment-header-2397" class="dsq-comment-header">
            <cite id="dsq-cite-2397">
                <span id="dsq-author-user-2397">Christian Wattengård</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2397" class="dsq-comment-body">
            <div id="dsq-comment-message-2397" class="dsq-comment-message"><p>That does not work when you are in edit mode&#8230; You need to know how to get out of edit mode before that works&#8230;</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-4" id="dsq-comment-2401">
        <div id="dsq-comment-header-2401" class="dsq-comment-header">
            <cite id="dsq-cite-2401">
                <span id="dsq-author-user-2401">Chris Wesseling</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2401" class="dsq-comment-body">
            <div id="dsq-comment-message-2401" class="dsq-comment-message"><p>Nah.. C-c will take you out to command-mode. So a frantic C-c pressing would do the trick&#8230; Show of hands of people that always press C-c or C-[ (aka ) just once&#8230;. 😉</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-4" id="dsq-comment-2485">
        <div id="dsq-comment-header-2485" class="dsq-comment-header">
            <cite id="dsq-cite-2485">
                <a id="dsq-author-user-2485" href="http://ralphembree.blg.lt" target="_blank" rel="nofollow">Ralph Embree</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2485" class="dsq-comment-body">
            <div id="dsq-comment-message-2485" class="dsq-comment-message"><p>I tested this. That message is not shown in Insert mode. Apparently, the OP did something else before typing it.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-4" id="dsq-comment-2536">
        <div id="dsq-comment-header-2536" class="dsq-comment-header">
            <cite id="dsq-cite-2536">
                <span id="dsq-author-user-2536">cedric simon</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2536" class="dsq-comment-body">
            <div id="dsq-comment-message-2536" class="dsq-comment-message"><p>C-c works like escape so you&#8217;ll be back into normal mode.<br />
Of course a second C-c will then display the message for quitting.<br />
But C-c is something we do more than once when we want to stop something no? 😉</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt depth-3" id="dsq-comment-2400">
        <div id="dsq-comment-header-2400" class="dsq-comment-header">
            <cite id="dsq-cite-2400">
                <a id="dsq-author-user-2400" href="https://schnell.news" target="_blank" rel="nofollow">Konstantin</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2400" class="dsq-comment-body">
            <div id="dsq-comment-message-2400" class="dsq-comment-message"><p>you wrote :quit in the object body and vim didn&#8217;t exits.<br />
then you read -&gt; type  :quit and it doesn&#8217;t exits.<br />
then you read again and type :q! and you&#8217;re totally amazed that this has actually worked&#8230;</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2452">
        <div id="dsq-comment-header-2452" class="dsq-comment-header">
            <cite id="dsq-cite-2452">
                <span id="dsq-author-user-2452">Per Wigren</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2452" class="dsq-comment-body">
            <div id="dsq-comment-message-2452" class="dsq-comment-message"><p>I think you meant &#8220;export VISUAL=nano&#8221;. Those extra spaces will give you &#8220;bash: export: `=&#8217;: not a valid identifier&#8221;. BTW, you can set it permanently with &#8220;vim ~/.bashrc&#8221; 😀</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2385">
        <div id="dsq-comment-header-2385" class="dsq-comment-header">
            <cite id="dsq-cite-2385">
                <span id="dsq-author-user-2385">Archibald Tuttle</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2385" class="dsq-comment-body">
            <div id="dsq-comment-message-2385" class="dsq-comment-message"><p>What is VIM?</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2387">
        <div id="dsq-comment-header-2387" class="dsq-comment-header">
            <cite id="dsq-cite-2387">
                <span id="dsq-author-user-2387">Neogene</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2387" class="dsq-comment-body">
            <div id="dsq-comment-message-2387" class="dsq-comment-message"><p>A text editor available in *nix/Linux distros.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2409">
        <div id="dsq-comment-header-2409" class="dsq-comment-header">
            <cite id="dsq-cite-2409">
                <span id="dsq-author-user-2409">birgersp</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2409" class="dsq-comment-body">
            <div id="dsq-comment-message-2409" class="dsq-comment-message"><p>It&#8217;s available for Windows users, too<br />
<a href="http://www.vim.org/download.php#pc" rel="nofollow">http://www.vim.org/download.php#pc</a></p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2393">
        <div id="dsq-comment-header-2393" class="dsq-comment-header">
            <cite id="dsq-cite-2393">
                <a id="dsq-author-user-2393" href="http://eltonjain.com" target="_blank" rel="nofollow">Elton Jain</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2393" class="dsq-comment-body">
            <div id="dsq-comment-message-2393" class="dsq-comment-message"><p>It&#8217;s a soap in India. You get solid bar and gel variants. It&#8217;s difficult to quit once you start using it.</p>
<p> <a href="https://uploads.disquscdn.com/images/4cfbae590261e5aa9a995540927feeeb98188bcb4502ceb4bc90d5ce6262b42e.jpg" rel="nofollow">https://uploads.disquscdn.com/images/4cfbae590261e5aa9a995540927feeeb98188bcb4502ceb4bc90d5ce6262b42e.jpg</a></p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2422">
        <div id="dsq-comment-header-2422" class="dsq-comment-header">
            <cite id="dsq-cite-2422">
                <span id="dsq-author-user-2422">Ammar Khan</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2422" class="dsq-comment-body">
            <div id="dsq-comment-message-2422" class="dsq-comment-message"><p>lol</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-3" id="dsq-comment-2436">
        <div id="dsq-comment-header-2436" class="dsq-comment-header">
            <cite id="dsq-cite-2436">
                <span id="dsq-author-user-2436">carpmeister</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2436" class="dsq-comment-body">
            <div id="dsq-comment-message-2436" class="dsq-comment-message"><p>Power of 100 Lemons!</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-3" id="dsq-comment-2471">
        <div id="dsq-comment-header-2471" class="dsq-comment-header">
            <cite id="dsq-cite-2471">
                <span id="dsq-author-user-2471">Andrew Poltavets</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2471" class="dsq-comment-body">
            <div id="dsq-comment-message-2471" class="dsq-comment-message"><p>If there are 100 lemons why did they draw a lime ?&#8230;</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2426">
        <div id="dsq-comment-header-2426" class="dsq-comment-header">
            <cite id="dsq-cite-2426">
                <span id="dsq-author-user-2426">agares</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2426" class="dsq-comment-body">
            <div id="dsq-comment-message-2426" class="dsq-comment-message"><p>BABY DONT HURT ME</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2461">
        <div id="dsq-comment-header-2461" class="dsq-comment-header">
            <cite id="dsq-cite-2461">
                <span id="dsq-author-user-2461">Haddaway</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2461" class="dsq-comment-body">
            <div id="dsq-comment-message-2461" class="dsq-comment-message"><p>Don&#8217;t hurt me&#8230;</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-4" id="dsq-comment-2463">
        <div id="dsq-comment-header-2463" class="dsq-comment-header">
            <cite id="dsq-cite-2463">
                <span id="dsq-author-user-2463">Jim Kerry</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2463" class="dsq-comment-body">
            <div id="dsq-comment-message-2463" class="dsq-comment-message"><p>NO MORE&#8230;</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-4" id="dsq-comment-2466">
        <div id="dsq-comment-header-2466" class="dsq-comment-header">
            <cite id="dsq-cite-2466">
                <span id="dsq-author-user-2466">Sergio Poppi</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2466" class="dsq-comment-body">
            <div id="dsq-comment-message-2466" class="dsq-comment-message"><p>you win!</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-4" id="dsq-comment-2478">
        <div id="dsq-comment-header-2478" class="dsq-comment-header">
            <cite id="dsq-cite-2478">
                <span id="dsq-author-user-2478">bidibodo</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2478" class="dsq-comment-body">
            <div id="dsq-comment-message-2478" class="dsq-comment-message"><p>no more &#8230;</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2445">
        <div id="dsq-comment-header-2445" class="dsq-comment-header">
            <cite id="dsq-cite-2445">
                <span id="dsq-author-user-2445">Gerard Brull</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2445" class="dsq-comment-body">
            <div id="dsq-comment-message-2445" class="dsq-comment-message"><p>In Spain we have another soap lol<br />
 <a href="https://uploads.disquscdn.com/images/ba205adb0456585578b413ece85ba242d9a6910adaafa36c86eb6961807bd1f8.jpg" rel="nofollow">https://uploads.disquscdn.com/images/ba205adb0456585578b413ece85ba242d9a6910adaafa36c86eb6961807bd1f8.jpg</a></p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2398">
        <div id="dsq-comment-header-2398" class="dsq-comment-header">
            <cite id="dsq-cite-2398">
                <span id="dsq-author-user-2398">Jamie Chapman</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2398" class="dsq-comment-body">
            <div id="dsq-comment-message-2398" class="dsq-comment-message"><p>This is more worrying than anything else.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2406">
        <div id="dsq-comment-header-2406" class="dsq-comment-header">
            <cite id="dsq-cite-2406">
                <span id="dsq-author-user-2406">Alston Huo</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2406" class="dsq-comment-body">
            <div id="dsq-comment-message-2406" class="dsq-comment-message"><p>I need &#8220;stack overflow helping one billion developers exit `nano`&#8221;</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2413">
        <div id="dsq-comment-header-2413" class="dsq-comment-header">
            <cite id="dsq-cite-2413">
                <span id="dsq-author-user-2413">Ben van der Stouwe (Jolijt)</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2413" class="dsq-comment-body">
            <div id="dsq-comment-message-2413" class="dsq-comment-message"><p>Exiting nano is way easier, it&#8217;s usually displayed in the bottem of the screen how to do it.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2416">
        <div id="dsq-comment-header-2416" class="dsq-comment-header">
            <cite id="dsq-cite-2416">
                <span id="dsq-author-user-2416">blsafjwiogh</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2416" class="dsq-comment-body">
            <div id="dsq-comment-message-2416" class="dsq-comment-message"><p>so does vim! and yet…</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-4" id="dsq-comment-2444">
        <div id="dsq-comment-header-2444" class="dsq-comment-header">
            <cite id="dsq-cite-2444">
                <span id="dsq-author-user-2444">Vannio</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2444" class="dsq-comment-body">
            <div id="dsq-comment-message-2444" class="dsq-comment-message"><p>Nano doesn&#8217;t have different modes for inserts or commands ¯_(ツ)_/¯</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-2411">
        <div id="dsq-comment-header-2411" class="dsq-comment-header">
            <cite id="dsq-cite-2411">
                <span id="dsq-author-user-2411">Dmitriy Zapevalov</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2411" class="dsq-comment-body">
            <div id="dsq-comment-message-2411" class="dsq-comment-message"><p>I think it is unfair to make representation by programming technology without taking into account the popularity of technology. Maybe C is so low only because not so many people use it comparing to jquery?</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2438">
        <div id="dsq-comment-header-2438" class="dsq-comment-header">
            <cite id="dsq-cite-2438">
                <span id="dsq-author-user-2438">Alex Che Korotkin</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2438" class="dsq-comment-body">
            <div id="dsq-comment-message-2438" class="dsq-comment-message"><p>The representation shows the percent of the Exit vim question among all vim questions within a technology. In other words, how often C/jquery programmers are stuck in vim compared to how often C/jquery programmers are interested in vim. Thus, the technology popularity does not affect the results here, at least directly.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2412">
        <div id="dsq-comment-header-2412" class="dsq-comment-header">
            <cite id="dsq-cite-2412">
                <span id="dsq-author-user-2412">Sergio Poppi</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2412" class="dsq-comment-body">
            <div id="dsq-comment-message-2412" class="dsq-comment-message"><p>Once I exited vim with &#8216;:X&#8217;, which in that version meant &#8220;crypt the file&#8221;. Obviously, I gave an unknown key to crypt typing randomly on the keyboard trying to exit that editor.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2480">
        <div id="dsq-comment-header-2480" class="dsq-comment-header">
            <cite id="dsq-cite-2480">
                <span id="dsq-author-user-2480">Victor</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2480" class="dsq-comment-body">
            <div id="dsq-comment-message-2480" class="dsq-comment-message"><p>You&#8217;re always could send $300 to bitcoin wallet 115p7UMMngoj1pMvkpHijcRdfJNXj6LrLn and wait for your decryption key back&#8230;</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-2415">
        <div id="dsq-comment-header-2415" class="dsq-comment-header">
            <cite id="dsq-cite-2415">
                <span id="dsq-author-user-2415">Graham Holden</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2415" class="dsq-comment-body">
            <div id="dsq-comment-message-2415" class="dsq-comment-message"><p>In the first graph, why is the X-axis titled &#8220;Month&#8221; but labelled in years? Did you accidentally exit VIM before changing the title?</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2423">
        <div id="dsq-comment-header-2423" class="dsq-comment-header">
            <cite id="dsq-cite-2423">
                <span id="dsq-author-user-2423">Mr. Meeseeks</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2423" class="dsq-comment-body">
            <div id="dsq-comment-message-2423" class="dsq-comment-message"><p>Because the datapoints represent months.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2417">
        <div id="dsq-comment-header-2417" class="dsq-comment-header">
            <cite id="dsq-cite-2417">
                <a id="dsq-author-user-2417" href="http://scorcher.org/" target="_blank" rel="nofollow">Jym Dyer</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2417" class="dsq-comment-body">
            <div id="dsq-comment-message-2417" class="dsq-comment-message"><p>🤣 Keys: :q!<br />
Mnemonic: &#8220;ESCape this COLON thing, qUIT and do NOT! RETurn&#8221;</p>
<p><a href="https://groups.google.com/forum/#!msg/alt.religion.emacs/0xXRxo75fiU/4LdisIZ9afwJ" rel="nofollow">https://groups.google.com/forum/#!msg/alt.religion.emacs/0xXRxo75fiU/4LdisIZ9afwJ</a></p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2430">
        <div id="dsq-comment-header-2430" class="dsq-comment-header">
            <cite id="dsq-cite-2430">
                <a id="dsq-author-user-2430" href="http://www.fractalizer.ru" target="_blank" rel="nofollow">Vladislav Rastrusny</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2430" class="dsq-comment-body">
            <div id="dsq-comment-message-2430" class="dsq-comment-message"><p>Is there another mnemonic to remember which letters to take from this mnemonic and which not? 🙂</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2433">
        <div id="dsq-comment-header-2433" class="dsq-comment-header">
            <cite id="dsq-cite-2433">
                <span id="dsq-author-user-2433">Nikola</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2433" class="dsq-comment-body">
            <div id="dsq-comment-message-2433" class="dsq-comment-message"><p>UIT?</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2420">
        <div id="dsq-comment-header-2420" class="dsq-comment-header">
            <cite id="dsq-cite-2420">
                <a id="dsq-author-user-2420" href="https://about.me/iliv" target="_blank" rel="nofollow">ILIV</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2420" class="dsq-comment-body">
            <div id="dsq-comment-message-2420" class="dsq-comment-message"><p>I&#8217;m a Ukrainian and I know how to exit VIM.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2421">
        <div id="dsq-comment-header-2421" class="dsq-comment-header">
            <cite id="dsq-cite-2421">
                <span id="dsq-author-user-2421">Xander Fender</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2421" class="dsq-comment-body">
            <div id="dsq-comment-message-2421" class="dsq-comment-message"><p>+1)</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-3" id="dsq-comment-2442">
        <div id="dsq-comment-header-2442" class="dsq-comment-header">
            <cite id="dsq-cite-2442">
                <span id="dsq-author-user-2442">Alexandr Rusalovskyy</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2442" class="dsq-comment-body">
            <div id="dsq-comment-message-2442" class="dsq-comment-message"><p>I&#8217;m ukrainian PL/SQL developer, working with IDE and i know how to quit Vi, ViM. By the way, how to quit Nano?!</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-4" id="dsq-comment-2446">
        <div id="dsq-comment-header-2446" class="dsq-comment-header">
            <cite id="dsq-cite-2446">
                <span id="dsq-author-user-2446">Bailey Swartz</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2446" class="dsq-comment-body">
            <div id="dsq-comment-message-2446" class="dsq-comment-message"><p>At least with nano the instructions for quitting are always right there in the lower left!</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-5" id="dsq-comment-2468">
        <div id="dsq-comment-header-2468" class="dsq-comment-header">
            <cite id="dsq-cite-2468">
                <span id="dsq-author-user-2468">Adam Bewsher</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2468" class="dsq-comment-body">
            <div id="dsq-comment-message-2468" class="dsq-comment-message"><p>Unless you are on a mac and type alt-x accidentally which just hides the help!</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt depth-4" id="dsq-comment-2450">
        <div id="dsq-comment-header-2450" class="dsq-comment-header">
            <cite id="dsq-cite-2450">
                <span id="dsq-author-user-2450">Anon</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2450" class="dsq-comment-body">
            <div id="dsq-comment-message-2450" class="dsq-comment-message"><p>Ctrl + X</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-4" id="dsq-comment-2454">
        <div id="dsq-comment-header-2454" class="dsq-comment-header">
            <cite id="dsq-cite-2454">
                <span id="dsq-author-user-2454">Maryna Cherniavska</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2454" class="dsq-comment-body">
            <div id="dsq-comment-message-2454" class="dsq-comment-message"><p>Or better still, how to search/copy/paste/delete/page in nano. For exiting, there&#8217;s always a helper down below.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2429">
        <div id="dsq-comment-header-2429" class="dsq-comment-header">
            <cite id="dsq-cite-2429">
                <span id="dsq-author-user-2429">Alex</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2429" class="dsq-comment-body">
            <div id="dsq-comment-message-2429" class="dsq-comment-message"><p>I&#8217;m from Crimea and I know how to exit from Ukraine.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-3" id="dsq-comment-2431">
        <div id="dsq-comment-header-2431" class="dsq-comment-header">
            <cite id="dsq-cite-2431">
                <span id="dsq-author-user-2431">Garry Filakhtov</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2431" class="dsq-comment-body">
            <div id="dsq-comment-message-2431" class="dsq-comment-message"><p>Is Crimea still part of the Ukraine at all?</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-4" id="dsq-comment-2453">
        <div id="dsq-comment-header-2453" class="dsq-comment-header">
            <cite id="dsq-cite-2453">
                <span id="dsq-author-user-2453">Maryna Cherniavska</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2453" class="dsq-comment-body">
            <div id="dsq-comment-message-2453" class="dsq-comment-message"><p>By national and international law, yes. In practice, no.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-5" id="dsq-comment-2455">
        <div id="dsq-comment-header-2455" class="dsq-comment-header">
            <cite id="dsq-cite-2455">
                <span id="dsq-author-user-2455">Garry Filakhtov</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2455" class="dsq-comment-body">
            <div id="dsq-comment-message-2455" class="dsq-comment-message"><p>Glad to hear yes, sad to hear no.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-5" id="dsq-comment-2464">
        <div id="dsq-comment-header-2464" class="dsq-comment-header">
            <cite id="dsq-cite-2464">
                <span id="dsq-author-user-2464">Mikhail Pobolovets</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2464" class="dsq-comment-body">
            <div id="dsq-comment-message-2464" class="dsq-comment-message"><p>Not sad at all. Just visit Crimea.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-5" id="dsq-comment-2472">
        <div id="dsq-comment-header-2472" class="dsq-comment-header">
            <cite id="dsq-cite-2472">
                <span id="dsq-author-user-2472">Vat What</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2472" class="dsq-comment-body">
            <div id="dsq-comment-message-2472" class="dsq-comment-message"><p>Being an alcoholic is also not sad at all! Just visit such a clinic. 🙂</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-5" id="dsq-comment-2474">
        <div id="dsq-comment-header-2474" class="dsq-comment-header">
            <cite id="dsq-cite-2474">
                <span id="dsq-author-user-2474">gurghet</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2474" class="dsq-comment-body">
            <div id="dsq-comment-message-2474" class="dsq-comment-message"><p>Can you exit alcohol?</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-5" id="dsq-comment-2500">
        <div id="dsq-comment-header-2500" class="dsq-comment-header">
            <cite id="dsq-cite-2500">
                <span id="dsq-author-user-2500">Vat What</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2500" class="dsq-comment-body">
            <div id="dsq-comment-message-2500" class="dsq-comment-message"><p>I tried to scream &#8220;exit&#8221; and &#8220;quit&#8221; but the only result was neighbors calling the police&#8230;<br />
What am I doing wrong?</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-5" id="dsq-comment-2502">
        <div id="dsq-comment-header-2502" class="dsq-comment-header">
            <cite id="dsq-cite-2502">
                <span id="dsq-author-user-2502">Vat What</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2502" class="dsq-comment-body">
            <div id="dsq-comment-message-2502" class="dsq-comment-message"><p>In Soviet Russia, alcohol exits you &#8211; not you exit alcohol!</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-5" id="dsq-comment-2503">
        <div id="dsq-comment-header-2503" class="dsq-comment-header">
            <cite id="dsq-cite-2503">
                <span id="dsq-author-user-2503">Mikhail Pobolovets</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2503" class="dsq-comment-body">
            <div id="dsq-comment-message-2503" class="dsq-comment-message"><p>So in your opinion people living in the Crimea are kind of alcoholics? Nice (not at all). (:</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt depth-4" id="dsq-comment-2460">
        <div id="dsq-comment-header-2460" class="dsq-comment-header">
            <cite id="dsq-cite-2460">
                <span id="dsq-author-user-2460">Robotex</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2460" class="dsq-comment-body">
            <div id="dsq-comment-message-2460" class="dsq-comment-message"><p>It&#8217;s temporally occupied by Russia and isolated from the world.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-5" id="dsq-comment-2535">
        <div id="dsq-comment-header-2535" class="dsq-comment-header">
            <cite id="dsq-cite-2535">
                <span id="dsq-author-user-2535">Redrerick</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2535" class="dsq-comment-body">
            <div id="dsq-comment-message-2535" class="dsq-comment-message"><p>It is more likely it was temporary given to Ukraine in the middle fifties by Russia and they got back to Russia by their own will when the democratically elected Ukrainian president was ousted by violent means, what it is usually called a &#8220;coup d&#8217;etat&#8221; in other contexts, and one of the first laws the coup government tried to pass was to ban Russian language use from Ukraine, being most of Crimeans by far Russian speakers the outcome shouldn&#8217;t surprise anyone with at least one functional neuron within its skull&#8230;</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt depth-4" id="dsq-comment-2465">
        <div id="dsq-comment-header-2465" class="dsq-comment-header">
            <cite id="dsq-cite-2465">
                <span id="dsq-author-user-2465">Andrii</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2465" class="dsq-comment-body">
            <div id="dsq-comment-message-2465" class="dsq-comment-message"><p>Yep, it is still a part of Ukraine.<br />
The same as Sudetenland is the part of Czech Republic.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even depth-3" id="dsq-comment-2441">
        <div id="dsq-comment-header-2441" class="dsq-comment-header">
            <cite id="dsq-cite-2441">
                <span id="dsq-author-user-2441">minkiu</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2441" class="dsq-comment-body">
            <div id="dsq-comment-message-2441" class="dsq-comment-message"><p>Savage for a morning comment.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-3" id="dsq-comment-2449">
        <div id="dsq-comment-header-2449" class="dsq-comment-header">
            <cite id="dsq-cite-2449">
                <span id="dsq-author-user-2449">Artem Mygaiev</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2449" class="dsq-comment-body">
            <div id="dsq-comment-message-2449" class="dsq-comment-message"><p>actually not 😀</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-3" id="dsq-comment-2470">
        <div id="dsq-comment-header-2470" class="dsq-comment-header">
            <cite id="dsq-cite-2470">
                <span id="dsq-author-user-2470">Andrew Poltavets</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2470" class="dsq-comment-body">
            <div id="dsq-comment-message-2470" class="dsq-comment-message"><p>It is your choice. Nothing more.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-3" id="dsq-comment-2496">
        <div id="dsq-comment-header-2496" class="dsq-comment-header">
            <cite id="dsq-cite-2496">
                <span id="dsq-author-user-2496">Albe Rosado</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2496" class="dsq-comment-body">
            <div id="dsq-comment-message-2496" class="dsq-comment-message"><p>I&#8217;m from Vim and i know how to exit Emacs</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-3" id="dsq-comment-2522">
        <div id="dsq-comment-header-2522" class="dsq-comment-header">
            <cite id="dsq-cite-2522">
                <a id="dsq-author-user-2522" href="http://www.alexandralouisematthews.com" target="_blank" rel="nofollow">Alexandra Louise</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2522" class="dsq-comment-body">
            <div id="dsq-comment-message-2522" class="dsq-comment-message"><p>That escalated quickly</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2527">
        <div id="dsq-comment-header-2527" class="dsq-comment-header">
            <cite id="dsq-cite-2527">
                <span id="dsq-author-user-2527">Gustavo</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2527" class="dsq-comment-body">
            <div id="dsq-comment-message-2527" class="dsq-comment-message"><p>Well, I bet you learned thru stackoverflow xD</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-3" id="dsq-comment-2529">
        <div id="dsq-comment-header-2529" class="dsq-comment-header">
            <cite id="dsq-cite-2529">
                <a id="dsq-author-user-2529" href="https://about.me/iliv" target="_blank" rel="nofollow">ILIV</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2529" class="dsq-comment-body">
            <div id="dsq-comment-message-2529" class="dsq-comment-message"><p>I learned how to do it long before StackOverflow came into existence ;D</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2428">
        <div id="dsq-comment-header-2428" class="dsq-comment-header">
            <cite id="dsq-cite-2428">
                <span id="dsq-author-user-2428">Sahib</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2428" class="dsq-comment-body">
            <div id="dsq-comment-message-2428" class="dsq-comment-message"><p><a href="https://uploads.disquscdn.com/images/a118302635e8a748d4a01fd2a03cb0f7629b433dff16ea8085b8d823c7f9ac81.png" rel="nofollow">https://uploads.disquscdn.com/images/a118302635e8a748d4a01fd2a03cb0f7629b433dff16ea8085b8d823c7f9ac81.png</a></p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2435">
        <div id="dsq-comment-header-2435" class="dsq-comment-header">
            <cite id="dsq-cite-2435">
                <span id="dsq-author-user-2435">Beobachter</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2435" class="dsq-comment-body">
            <div id="dsq-comment-message-2435" class="dsq-comment-message"><p>Also, just use ed(1) where :q is just a mere &#8220;q&#8221;.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2473">
        <div id="dsq-comment-header-2473" class="dsq-comment-header">
            <cite id="dsq-cite-2473">
                <span id="dsq-author-user-2473">Jürgen Erhard</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2473" class="dsq-comment-body">
            <div id="dsq-comment-message-2473" class="dsq-comment-message"><p>ed is the standard text editor!</p>
<p><a href="https://www.gnu.org/fun/jokes/ed-msg.html" rel="nofollow">https://www.gnu.org/fun/jokes/ed-msg.html</a></p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-even depth-1" id="dsq-comment-2437">
        <div id="dsq-comment-header-2437" class="dsq-comment-header">
            <cite id="dsq-cite-2437">
                <span id="dsq-author-user-2437">Sahib</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2437" class="dsq-comment-body">
            <div id="dsq-comment-message-2437" class="dsq-comment-message"><p><a href="https://uploads.disquscdn.com/images/7961869b49c900a4ebc71e9278436e626fab36bad2e6feeaa0885b764a74bd60.png" rel="nofollow">https://uploads.disquscdn.com/images/7961869b49c900a4ebc71e9278436e626fab36bad2e6feeaa0885b764a74bd60.png</a></p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2477">
        <div id="dsq-comment-header-2477" class="dsq-comment-header">
            <cite id="dsq-cite-2477">
                <span id="dsq-author-user-2477">Kamlekar Venkateshwar</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2477" class="dsq-comment-body">
            <div id="dsq-comment-message-2477" class="dsq-comment-message"><p>OMG this gets funnier if I see it again and again.. lol</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2511">
        <div id="dsq-comment-header-2511" class="dsq-comment-header">
            <cite id="dsq-cite-2511">
                <span id="dsq-author-user-2511">Tiexin Guo</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2511" class="dsq-comment-body">
            <div id="dsq-comment-message-2511" class="dsq-comment-message"><p>What&#8217;s this&#8230; I don&#8217;t get it. Could someone explain? ty!</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-2443">
        <div id="dsq-comment-header-2443" class="dsq-comment-header">
            <cite id="dsq-cite-2443">
                <span id="dsq-author-user-2443">Michael Bruce</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2443" class="dsq-comment-body">
            <div id="dsq-comment-message-2443" class="dsq-comment-message"><p>`for vimpid in $(ps ex | grep vim | cut -d &#8216; &#8216; -f1); do kill $vimpid; done; echo &#8216;no problem&#8217;`</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2447">
        <div id="dsq-comment-header-2447" class="dsq-comment-header">
            <cite id="dsq-cite-2447">
                <span id="dsq-author-user-2447">Elias Van Ootegem</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2447" class="dsq-comment-body">
            <div id="dsq-comment-message-2447" class="dsq-comment-message"><p>or more efficiently: kill -9 $(pgrep vim)</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2448">
        <div id="dsq-comment-header-2448" class="dsq-comment-header">
            <cite id="dsq-cite-2448">
                <span id="dsq-author-user-2448">Jonathan Dowland</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2448" class="dsq-comment-body">
            <div id="dsq-comment-message-2448" class="dsq-comment-message"><p>more safely, too, since you won&#8217;t send kill signals to any process that has vim in any substring of its command name or arguments</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-4" id="dsq-comment-2475">
        <div id="dsq-comment-header-2475" class="dsq-comment-header">
            <cite id="dsq-cite-2475">
                <span id="dsq-author-user-2475">Steffen Panning</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2475" class="dsq-comment-body">
            <div id="dsq-comment-message-2475" class="dsq-comment-message"><p>unless you are on solaris&#8230;</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt depth-3" id="dsq-comment-2457">
        <div id="dsq-comment-header-2457" class="dsq-comment-header">
            <cite id="dsq-cite-2457">
                <span id="dsq-author-user-2457">Peter Taylor</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2457" class="dsq-comment-body">
            <div id="dsq-comment-message-2457" class="dsq-comment-message"><p>I can&#8217;t be the only person who uses a distro which has killall.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-4" id="dsq-comment-2476">
        <div id="dsq-comment-header-2476" class="dsq-comment-header">
            <cite id="dsq-cite-2476">
                <span id="dsq-author-user-2476">Charlie</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2476" class="dsq-comment-body">
            <div id="dsq-comment-message-2476" class="dsq-comment-message"><p>Or pkill , these are probably the same people asking how to exit vim.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-5" id="dsq-comment-2542">
        <div id="dsq-comment-header-2542" class="dsq-comment-header">
            <cite id="dsq-cite-2542">
                <span id="dsq-author-user-2542">Elias Van Ootegem</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2542" class="dsq-comment-body">
            <div id="dsq-comment-message-2542" class="dsq-comment-message"><p>Jesus Christ&#8230;. the shame. I saw the overly convoluted loop, replaced ps | grep with pgrep, but didn&#8217;t even think of pkill.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2531">
        <div id="dsq-comment-header-2531" class="dsq-comment-header">
            <cite id="dsq-cite-2531">
                <span id="dsq-author-user-2531">Matias Fernandez</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2531" class="dsq-comment-body">
            <div id="dsq-comment-message-2531" class="dsq-comment-message"><p>killall -9 vim</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2456">
        <div id="dsq-comment-header-2456" class="dsq-comment-header">
            <cite id="dsq-cite-2456">
                <span id="dsq-author-user-2456">David Pape</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2456" class="dsq-comment-body">
            <div id="dsq-comment-message-2456" class="dsq-comment-message"><p>Wow.  Did not realize vim was hard.  gg devs, gg.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2462">
        <div id="dsq-comment-header-2462" class="dsq-comment-header">
            <cite id="dsq-cite-2462">
                <span id="dsq-author-user-2462">Mememaster Alex</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2462" class="dsq-comment-body">
            <div id="dsq-comment-message-2462" class="dsq-comment-message"><p>well you have to learn it SOMEWHERE, so.. what&#8217;s your point? that&#8217;s a very basic question, and VIM isn&#8217;t exactly intuitive to use for a newcomer<br />
i first came across it when using git bash and the natural response was to google the answer</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2467">
        <div id="dsq-comment-header-2467" class="dsq-comment-header">
            <cite id="dsq-cite-2467">
                <span id="dsq-author-user-2467">David Pape</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2467" class="dsq-comment-body">
            <div id="dsq-comment-message-2467" class="dsq-comment-message"><p>I suppose that&#8217;s true.  Back when I was learning to use linux, it was drilled into me to man anything new before using it, so I actually read the manpage for vi/vim.  I think my surprise was more focused on the idea that someone would run random linux commands, blindly, without knowing how they work.</p>
<p>That&#8217;s systems/devops vs pure devs though.  Cheers!</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-4" id="dsq-comment-2481">
        <div id="dsq-comment-header-2481" class="dsq-comment-header">
            <cite id="dsq-cite-2481">
                <span id="dsq-author-user-2481">Andras Racz</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2481" class="dsq-comment-body">
            <div id="dsq-comment-message-2481" class="dsq-comment-message"><p>Most noobs don’t start vim on purpose, but it is set up on their system as the default editor for some CLI commands (git etc).</p>
<p>I suppose this was written in the post though. RTFP. Cheers!</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-4" id="dsq-comment-2517">
        <div id="dsq-comment-header-2517" class="dsq-comment-header">
            <cite id="dsq-cite-2517">
                <span id="dsq-author-user-2517">Nicolas L</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2517" class="dsq-comment-body">
            <div id="dsq-comment-message-2517" class="dsq-comment-message"><p>/r/iamverysmart</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2459">
        <div id="dsq-comment-header-2459" class="dsq-comment-header">
            <cite id="dsq-cite-2459">
                <span id="dsq-author-user-2459">Dmitry Bogdanov</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2459" class="dsq-comment-body">
            <div id="dsq-comment-message-2459" class="dsq-comment-message"><p><a href="https://uploads.disquscdn.com/images/62956bbc61c3860584948b164628ce141ec547e0fd697a6bb27eb58e240cf7b8.jpg" rel="nofollow">https://uploads.disquscdn.com/images/62956bbc61c3860584948b164628ce141ec547e0fd697a6bb27eb58e240cf7b8.jpg</a></p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2487">
        <div id="dsq-comment-header-2487" class="dsq-comment-header">
            <cite id="dsq-cite-2487">
                <span id="dsq-author-user-2487">Vladislav Derbenev</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2487" class="dsq-comment-body">
            <div id="dsq-comment-message-2487" class="dsq-comment-message"><p>Someone explain me this</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-3" id="dsq-comment-2489">
        <div id="dsq-comment-header-2489" class="dsq-comment-header">
            <cite id="dsq-cite-2489">
                <span id="dsq-author-user-2489">brahim elmssilha</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2489" class="dsq-comment-body">
            <div id="dsq-comment-message-2489" class="dsq-comment-message"><p>Its like saying you dont have to debug code if you dont write code</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2495">
        <div id="dsq-comment-header-2495" class="dsq-comment-header">
            <cite id="dsq-cite-2495">
                <span id="dsq-author-user-2495">Albe Rosado</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2495" class="dsq-comment-body">
            <div id="dsq-comment-message-2495" class="dsq-comment-message"><p>haha awesome!!!</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2507">
        <div id="dsq-comment-header-2507" class="dsq-comment-header">
            <cite id="dsq-cite-2507">
                <span id="dsq-author-user-2507">Michael Davidson</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2507" class="dsq-comment-body">
            <div id="dsq-comment-message-2507" class="dsq-comment-message"><p>typing git commit from the cmd line opens vim, no matter what code you are writing, so this meme doesnt make any sense</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-3" id="dsq-comment-2509">
        <div id="dsq-comment-header-2509" class="dsq-comment-header">
            <cite id="dsq-cite-2509">
                <span id="dsq-author-user-2509">Dmitry Bogdanov</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2509" class="dsq-comment-body">
            <div id="dsq-comment-message-2509" class="dsq-comment-message"><p><a href="https://uploads.disquscdn.com/images/b497991fadb6202b0c315972420079cc6b2e78be9b6cbcfa1393c93edd49abae.jpg" rel="nofollow">https://uploads.disquscdn.com/images/b497991fadb6202b0c315972420079cc6b2e78be9b6cbcfa1393c93edd49abae.jpg</a></p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-4" id="dsq-comment-2510">
        <div id="dsq-comment-header-2510" class="dsq-comment-header">
            <cite id="dsq-cite-2510">
                <span id="dsq-author-user-2510">Michael Davidson</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2510" class="dsq-comment-body">
            <div id="dsq-comment-message-2510" class="dsq-comment-message"><p>because you never commit anything because your code sucks &#8211; is that what you&#8217;re implying here?</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-4" id="dsq-comment-2512">
        <div id="dsq-comment-header-2512" class="dsq-comment-header">
            <cite id="dsq-cite-2512">
                <span id="dsq-author-user-2512">Michael Davidson</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2512" class="dsq-comment-body">
            <div id="dsq-comment-message-2512" class="dsq-comment-message"><p>because angular devs dont code? is that what you&#8217;re trying to say here?</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-5" id="dsq-comment-2543">
        <div id="dsq-comment-header-2543" class="dsq-comment-header">
            <cite id="dsq-cite-2543">
                <span id="dsq-author-user-2543">Elias Van Ootegem</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2543" class="dsq-comment-body">
            <div id="dsq-comment-message-2543" class="dsq-comment-message"><p>Maybe because you shouldn&#8217;t be committing angularjs code in the first place, especially if you can&#8217;t push a commit without opening an editor (git commit -m &#8216;my message&#8217; &amp;&amp; git push)</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt depth-3" id="dsq-comment-2534">
        <div id="dsq-comment-header-2534" class="dsq-comment-header">
            <cite id="dsq-cite-2534">
                <span id="dsq-author-user-2534">Redrerick</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2534" class="dsq-comment-body">
            <div id="dsq-comment-message-2534" class="dsq-comment-message"><p>Which OS are you using? In Linux at least you can replace vim with other editor just by setting the EDITOR environment variable.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-even depth-1" id="dsq-comment-2479">
        <div id="dsq-comment-header-2479" class="dsq-comment-header">
            <cite id="dsq-cite-2479">
                <span id="dsq-author-user-2479">Y</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2479" class="dsq-comment-body">
            <div id="dsq-comment-message-2479" class="dsq-comment-message"><p>I have a feeling that the tag graph would be similar to most popular tag graph overall&#8230;not sure it points to which developers are more likely to get stuck</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2486">
        <div id="dsq-comment-header-2486" class="dsq-comment-header">
            <cite id="dsq-cite-2486">
                <span id="dsq-author-user-2486">David Robinson</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2486" class="dsq-comment-body">
            <div id="dsq-comment-message-2486" class="dsq-comment-message"><p>To clarify: the tag shows the amount of traffic to that question <i>divided by the total Vim traffic among those users</i>. This, it&#8217;s not saying &#8220;7% of people stuck in Vim use JQuery,&#8221; it&#8217;s saying something closer to &#8220;7% of people that use JQuery get stuck.&#8221;</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-3" id="dsq-comment-2539">
        <div id="dsq-comment-header-2539" class="dsq-comment-header">
            <cite id="dsq-cite-2539">
                <span id="dsq-author-user-2539">Y</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2539" class="dsq-comment-body">
            <div id="dsq-comment-message-2539" class="dsq-comment-message"><p>Thanks for clarifying!</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-2484">
        <div id="dsq-comment-header-2484" class="dsq-comment-header">
            <cite id="dsq-cite-2484">
                <span id="dsq-author-user-2484">L</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2484" class="dsq-comment-body">
            <div id="dsq-comment-message-2484" class="dsq-comment-message"><p>Hey.<br />
Here&#8217;s a book that might help:</p>
<p><a href="https://vimebook.com/static/en-vim-extract-chap1.pdf" rel="nofollow">https://vimebook.com/static/en-vim-extract-chap1.pdf</a></p>
<p>Enjoy,</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even thread-even depth-1" id="dsq-comment-2488">
        <div id="dsq-comment-header-2488" class="dsq-comment-header">
            <cite id="dsq-cite-2488">
                <span id="dsq-author-user-2488">reb</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2488" class="dsq-comment-body">
            <div id="dsq-comment-message-2488" class="dsq-comment-message"><p>If the UI instruction for how to perform a task does not adequately explain how to perform that task, the UI is bad.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-2491">
        <div id="dsq-comment-header-2491" class="dsq-comment-header">
            <cite id="dsq-cite-2491">
                <a id="dsq-author-user-2491" href="https://www.facebook.com/skaterguitarist" target="_blank" rel="nofollow">Kool Wolff</a>
            </cite>
        </div>
        <div id="dsq-comment-body-2491" class="dsq-comment-body">
            <div id="dsq-comment-message-2491" class="dsq-comment-message"><p>How about you stop joking &amp; cut to the chase?</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even thread-even depth-1" id="dsq-comment-2492">
        <div id="dsq-comment-header-2492" class="dsq-comment-header">
            <cite id="dsq-cite-2492">
                <span id="dsq-author-user-2492">Nick</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2492" class="dsq-comment-body">
            <div id="dsq-comment-message-2492" class="dsq-comment-message"><p>Hilarious. If only they&#8217;d been using emacs.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2497">
        <div id="dsq-comment-header-2497" class="dsq-comment-header">
            <cite id="dsq-cite-2497">
                <span id="dsq-author-user-2497">ranger@mybroadband</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2497" class="dsq-comment-body">
            <div id="dsq-comment-message-2497" class="dsq-comment-message"><p>But then they would ask why &#8216;git commit -a&#8217; is so slow compared to their previous git commands &#8230;</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2493">
        <div id="dsq-comment-header-2493" class="dsq-comment-header">
            <cite id="dsq-cite-2493">
                <span id="dsq-author-user-2493">Kakubei</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2493" class="dsq-comment-body">
            <div id="dsq-comment-message-2493" class="dsq-comment-message"><p>Just use Emacs. Let the holy wars begin!</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2533">
        <div id="dsq-comment-header-2533" class="dsq-comment-header">
            <cite id="dsq-cite-2533">
                <span id="dsq-author-user-2533">Redrerick</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2533" class="dsq-comment-body">
            <div id="dsq-comment-message-2533" class="dsq-comment-message"><p>That Holy Wars started decades ago and never ended. They just seem to have signed an armistice&#8230;</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2540">
        <div id="dsq-comment-header-2540" class="dsq-comment-header">
            <cite id="dsq-cite-2540">
                <span id="dsq-author-user-2540">Gerhard Gappmeier</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2540" class="dsq-comment-body">
            <div id="dsq-comment-message-2540" class="dsq-comment-message"><p>Emacs has a built-in vim-mode. So you can exit Emacs as &#8220;easily&#8221; as Vim using ZZ instead of CTRL-X CTRL-C 🙂</p>
<p>People used to say &#8220;Emacs is a great operating system, lacking only a decent editor&#8221;. With Vim-mode this is n&#8217;t true anymore.</p>
<p>Vim rules 😉</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2494">
        <div id="dsq-comment-header-2494" class="dsq-comment-header">
            <cite id="dsq-cite-2494">
                <span id="dsq-author-user-2494">Umang Gupta</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2494" class="dsq-comment-body">
            <div id="dsq-comment-message-2494" class="dsq-comment-message"><p>I used Vim for almost 2 years, but then I found out how to exit.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2499">
        <div id="dsq-comment-header-2499" class="dsq-comment-header">
            <cite id="dsq-cite-2499">
                <span id="dsq-author-user-2499">Jon Green</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2499" class="dsq-comment-body">
            <div id="dsq-comment-message-2499" class="dsq-comment-message"><p>Proud that my C/C++ colleagues are least likely to consider this a problem! (Well, apart from Rubyists &#8211; who&#8217;d&#8217;a thunk that?)</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2501">
        <div id="dsq-comment-header-2501" class="dsq-comment-header">
            <cite id="dsq-cite-2501">
                <span id="dsq-author-user-2501">Mr. Xcoder</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2501" class="dsq-comment-body">
            <div id="dsq-comment-message-2501" class="dsq-comment-message"><p>&#8220;(Well, apart from Rubyists &#8211; who&#8217;d&#8217;a thunk that?)&#8221; &#8211; definetly not those who use jquery.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2505">
        <div id="dsq-comment-header-2505" class="dsq-comment-header">
            <cite id="dsq-cite-2505">
                <span id="dsq-author-user-2505">Andrew Raymer</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2505" class="dsq-comment-body">
            <div id="dsq-comment-message-2505" class="dsq-comment-message"><p>It&#8217;s the artisanal vim users.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2506">
        <div id="dsq-comment-header-2506" class="dsq-comment-header">
            <cite id="dsq-cite-2506">
                <span id="dsq-author-user-2506">Dave Franken</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2506" class="dsq-comment-body">
            <div id="dsq-comment-message-2506" class="dsq-comment-message"><p>When I type &#8220;:q&#8221; it just says &#8220;E488: Trailing characters&#8221;<br />
Still stuck&#8230; :o(</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-2" id="dsq-comment-2525">
        <div id="dsq-comment-header-2525" class="dsq-comment-header">
            <cite id="dsq-cite-2525">
                <span id="dsq-author-user-2525">gzulux</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2525" class="dsq-comment-body">
            <div id="dsq-comment-message-2525" class="dsq-comment-message"><p>Comment Win.</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-2" id="dsq-comment-2532">
        <div id="dsq-comment-header-2532" class="dsq-comment-header">
            <cite id="dsq-cite-2532">
                <span id="dsq-author-user-2532">Redrerick</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2532" class="dsq-comment-body">
            <div id="dsq-comment-message-2532" class="dsq-comment-message"><p>Try typing :Q with caps, maybe your computer is deaf&#8230;</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-3" id="dsq-comment-2537">
        <div id="dsq-comment-header-2537" class="dsq-comment-header">
            <cite id="dsq-cite-2537">
                <span id="dsq-author-user-2537">Tom Che</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2537" class="dsq-comment-body">
            <div id="dsq-comment-message-2537" class="dsq-comment-message"><p>If it really is deaf you should try :Q!</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-4" id="dsq-comment-2541">
        <div id="dsq-comment-header-2541" class="dsq-comment-header">
            <cite id="dsq-cite-2541">
                <span id="dsq-author-user-2541">Redrerick</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2541" class="dsq-comment-body">
            <div id="dsq-comment-message-2541" class="dsq-comment-message"><p>Good point</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2508">
        <div id="dsq-comment-header-2508" class="dsq-comment-header">
            <cite id="dsq-cite-2508">
                <span id="dsq-author-user-2508">Đặng Huỳnh Bảo Long</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2508" class="dsq-comment-body">
            <div id="dsq-comment-message-2508" class="dsq-comment-message"><p>I used Vim for almost 2 years, but then I found out how to exit.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2514">
        <div id="dsq-comment-header-2514" class="dsq-comment-header">
            <cite id="dsq-cite-2514">
                <span id="dsq-author-user-2514">Ismail Akram</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2514" class="dsq-comment-body">
            <div id="dsq-comment-message-2514" class="dsq-comment-message"><p>I don&#8217;t get the context what means exit vim ? Means switching to other text editor or IDE?</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-3" id="dsq-comment-2518">
        <div id="dsq-comment-header-2518" class="dsq-comment-header">
            <cite id="dsq-cite-2518">
                <span id="dsq-author-user-2518">tankist</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2518" class="dsq-comment-body">
            <div id="dsq-comment-message-2518" class="dsq-comment-message"><p>No, it means how to quit the program, shutdown it</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt depth-3" id="dsq-comment-2521">
        <div id="dsq-comment-header-2521" class="dsq-comment-header">
            <cite id="dsq-cite-2521">
                <span id="dsq-author-user-2521">Juck</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2521" class="dsq-comment-body">
            <div id="dsq-comment-message-2521" class="dsq-comment-message"><p>going back to the terminal</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even depth-2" id="dsq-comment-2515">
        <div id="dsq-comment-header-2515" class="dsq-comment-header">
            <cite id="dsq-cite-2515">
                <span id="dsq-author-user-2515">Gustavo Martins de Souza</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2515" class="dsq-comment-body">
            <div id="dsq-comment-message-2515" class="dsq-comment-message"><p>I see what you did there.</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1" id="dsq-comment-2519">
        <div id="dsq-comment-header-2519" class="dsq-comment-header">
            <cite id="dsq-cite-2519">
                <span id="dsq-author-user-2519">Kamlekar Venkateshwar</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2519" class="dsq-comment-body">
            <div id="dsq-comment-message-2519" class="dsq-comment-message"><p><a href="https://twitter.com/iamdevloper/status/867325703506853889" rel="nofollow">https://twitter.com/iamdevloper/status/867325703506853889</a></p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-2523">
        <div id="dsq-comment-header-2523" class="dsq-comment-header">
            <cite id="dsq-cite-2523">
                <span id="dsq-author-user-2523">Juho Hiltunen</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2523" class="dsq-comment-body">
            <div id="dsq-comment-message-2523" class="dsq-comment-message"><p>This is good reason to use nano, just press Ctrl+x. Logical.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment odd alt depth-2" id="dsq-comment-2530">
        <div id="dsq-comment-header-2530" class="dsq-comment-header">
            <cite id="dsq-cite-2530">
                <span id="dsq-author-user-2530">kamranayub</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2530" class="dsq-comment-body">
            <div id="dsq-comment-message-2530" class="dsq-comment-message"><p>I love nano! I&#8217;m a native Windows dev, and in my Raspberry Pi tutorials I suggest using nano since people new to Linux might find VIM intimidating&#8230; Ctrl-X to exit, Ctrl-O to save. DONE.</p>
</div>
        </div>

    <ul class="children">
    <li class="comment even depth-3" id="dsq-comment-2538">
        <div id="dsq-comment-header-2538" class="dsq-comment-header">
            <cite id="dsq-cite-2538">
                <span id="dsq-author-user-2538">Denys Slipetskyy</span>
            </cite>
        </div>
        <div id="dsq-comment-body-2538" class="dsq-comment-body">
            <div id="dsq-comment-message-2538" class="dsq-comment-message"><p>well, it is subjective .. :wq for example, much more meaningful for me &#8230; Vim is a great tool &#8230; just need to catch an idea and you will appreciate it</p>
</div>
        </div>

    </li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
            </ul>


        </div>

    </div>

</div>
                    </div>
                </div>
            </div>
    </article>
        </main><!-- #main -->
    </div><!-- #primary -->


    <footer class="footer">
        <div class="inner-container">
            <div class="-row">

                <div class="-col2 media-padded">
                                            <div id="nav_menu-16" class="widget widget_nav_menu"><h4 class="widgettitle">Business Products</h4><div class="menu-business-products-container"><ul id="menu-business-products" class="menu"><li id="menu-item-5600" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5600"><a href="https://www.stackoverflowbusiness.com/talent">Hire Developers</a></li>
<li id="menu-item-5601" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5601"><a href="https://www.stackoverflowbusiness.com/advertise">Advertise With Us</a></li>
<li id="menu-item-5602" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5602"><a href="https://www.stackoverflowbusiness.com/enterprise">Get Stack Overflow Enterprise</a></li>
</ul></div></div>                                    </div>
                <div class="-col2 media-padded">
                                            <div id="nav_menu-17" class="widget widget_nav_menu"><h4 class="widgettitle">Company</h4><div class="menu-company-footer-menu-container"><ul id="menu-company-footer-menu" class="menu"><li id="menu-item-5603" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5603"><a href="https://stackoverflow.com/company/about">About Us</a></li>
<li id="menu-item-5604" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5604"><a href="https://stackoverflow.com/company/work-here">Work Here</a></li>
<li id="menu-item-5605" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5605"><a href="http://meta.stackoverflow.com/">Any feedback?</a></li>
</ul></div></div>                                    </div>
                <div class="-col2 media-padded">
                                            <div id="nav_menu-18" class="widget widget_nav_menu"><h4 class="widgettitle">Support</h4><div class="menu-support-footer-menu-container"><ul id="menu-support-footer-menu" class="menu"><li id="menu-item-5606" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5606"><a href="https://stackexchange.com/about/contact">Contact Us</a></li>
<li id="menu-item-5607" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5607"><a href="https://stackexchange.com/legal/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-5608" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5608"><a href="https://stackexchange.com/legal">Legal</a></li>
</ul></div></div>                                    </div>
                <div class="-col2 media-padded">
                                            <div id="nav_menu-19" class="widget widget_nav_menu"><h4 class="widgettitle">Connect</h4><div class="menu-connect-footer-menu-container"><ul id="menu-connect-footer-menu" class="menu"><li id="menu-item-5609" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5609"><a href="https://www.facebook.com/officialstackoverflow/">Facebook</a></li>
<li id="menu-item-5610" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5610"><a href="https://twitter.com/stackoverflow">Twitter</a></li>
<li id="menu-item-5611" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5611"><a href="https://www.linkedin.com/company/stack-overflow">Linkedin</a></li>
</ul></div></div>                                    </div>
                <div class="-col2 media-padded">
                    <div class="-col2 media-padded">
                                            </div>
                </div>
                <div class="-col2 media-padded">
                    <p><strong>&copy; 2017 Stack Overflow</strong></p>
                </div>
            </div>
        </div>
    </footer>

		<!-- Google Analytics -->
		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
					(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
				m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

			ga('create', 'UA-5620270-58', 'auto');
			ga('send', 'pageview');
		</script>
		<!-- End Google Analytics -->

		        <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4ececeb97191880b"></script><script type='text/javascript' src='https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/themes/stackoverflow/assets/js/stackoverflow.min.js?ver=0.1.3'></script>
<script type='text/javascript' src='https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-includes/js/wp-embed.min.js?ver=4.7.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.7.5","language":""},"disqusIdentifier":"7147 https:\/\/stackoverflow.blog\/?p=7147","disqusShortname":"stackoverflowblog","disqusTitle":"Stack Overflow: Helping One Million Developers Exit Vim","disqusUrl":"https:\/\/stackoverflow.blog\/2017\/05\/23\/stack-overflow-helping-one-million-developers-exit-vim\/","options":{"manualSync":false},"postId":"7147"};
/* ]]> */
</script>
<script type='text/javascript' src='https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.7.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"stackoverflowblog"};
/* ]]> */
</script>
<script type='text/javascript' src='https://zgab33vy595fw5zq-zippykid.netdna-ssl.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=4.7.5'></script>
	  <script type="text/javascript">
		(function() {
		  var t   = document.createElement( 'script' );
		  t.type  = 'text/javascript';
		  t.async = true;
		  t.id    = 'gauges-tracker';
		  t.setAttribute( 'data-site-id', '58a295c34b2ffa62041185f8' );
		  t.src = '//secure.gaug.es/track.js';
		  var s = document.getElementsByTagName( 'script' )[0];
		  s.parentNode.insertBefore( t, s );
		})();
	  </script>
	  	</body>
</html>
<!--
	generated 238 seconds ago
	generated in 0.919 seconds
	served from batcache in 0.005 seconds
	expires in 62 seconds
-->
